Mailinglist Archive: opensuse (2806 mails)

< Previous Next >
Re: [opensuse] SuSE11 lppasswd -a -g sys root, access denied (SOLVED), well sort of..
  • From: russbucket <russbucket@xxxxxxx>
  • Date: Fri, 25 Jul 2008 08:59:25 -0700
  • Message-id: <200807250859.25147.russbucket@xxxxxxx>
On Friday 25 July 2008 08:35:58 am Joe Morris wrote:
On 07/25/2008 09:26 PM, Verner Kjærsgaard wrote:
- thank you for your help!
- it didn't change a thing :-(, same bug with lppasswd.

I don't believe it is a bug, it was a change in cups introduced in IIRC
cups 1.2. I think it was in the 10.2 release notes. RunAsUser was
deprecated IIRC.

I don't understand that...for starters root's pw on this particular
system does not adhere to what CUPS normally demands in terms of
complexity and so.

Furthermore, on all the other systems I know of, I must create a CUPS
use by issuing lppasswd and so forth, before I can use the web interface.

What version of cups?

No so anymore..

Anyhow, it's solved, but not understood...thanks again!

FYI: here is a list from /etc/:
vk@beethoven:/etc> ls -ld cups
drwxrwxr-x 6 root lp 4096 25 jul 15:18 cups

Who should own cups?

Permissions are correct.

Joe Morris
Registered Linux user 231871 running openSUSE 10.3 x86_64

I seen to remember this also. I know the last couple of versions of CUPS would
not work with lppasswd. I have to log in as root with the actual root passwd.
the above permissions are the same as mine.

Linux register user 441463
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups