Mailinglist Archive: opensuse (4264 mails)

< Previous Next >
[opensuse] Re: 10.3 No Java Runtime for Firefox?
  • From: Eberhard Roloff <tuxebi@xxxxxx>
  • Date: Sat, 20 Oct 2007 15:29:46 +0200
  • Message-id: <ffcvs9$t42$1@xxxxxxxxxxxxx>
Bryen wrote:
> On Sat, 2007-10-20 at 12:29 +0200, Eberhard Roloff wrote:
>> Joe Morris (NTM) wrote:
>>> On 10/20/2007 02:11 PM, David C. Rankin J.D. P.E. wrote:
>>>>     What say the gurus about getting java to work in firefox? Specifically,
>>>> I want to see:
>>> Worked here.  I have Blackdown java 1.4.2 installed for my 64 bit
>>> browser.  AFAIK, it is the only 64 bit java plugin.
>>>> Which has always worked in my suse install since 9.0. Why not in 10.3?
>>> What arch?  If you run i586, this would not apply.
>> This webpage works greatly here with 10.3 i586
>> What I did:
>> -found that the command "java" did not work anymore, since there was no
>> /usr/bin/java anymore.
>> Tried with
>> -Found out that the link /usr/bin/java pointed to
>> /etc/alternatives/java, which in turn pointed to the wrong, not
>> (anymore) existing sun java jre.
>> Corrected the link manually from pointing to
>> /usr/lib/jvm/jre-1.6.0.u2-sun/bin/java, which was not there, anmore
>> to correctly pointing to
>> /usr/lib/jvm/jre-1.6.0.u3-sun/bin/java which exists.
>> and this was it.
>> Actually sometimes I think windows users are happy campers, since they
>> can continue with their work instead of tracking down this mess.
>> Kind regards
>> Eberhard
> Eberhard...  using ll, I can see the broken symlinks you are referring
> to.  For those of us not familiar with how to change symlinks, can you
> give us the exact commands to use step by step to resolve this?
> Thanks,
sure. You are wellcome.

Just to warm up:
-"java" yields "command not found"
-as root "find / -name "java" yields many things java, among them

Now for something real:

ls -la  /usr/bin/java:
.... /usr/bin/java -> /etc/alternatives/java

then ls -la /etc/alternatives/java
.../etc/alternatives/java -> /usr/lib/jvm/jre-1.6.0.u2-sun/bin/java
(which does not exist!)

go to /etc/alternatives and delete the existing link to the non existing
java executable:
as root:
cd /etc/alternatives
rm java

create a new link there with the name "java" to the existing java
executable. Beforehand, check on your system, whether java is REALLY
there, where you want to link to!

ln -s /usr/lib/jvm/jre-1.6.0.u3-sun/bin/java ./java

double check with:
ls la java

then as ordinary user, check, whether "java" yields a long explanation
of all the parameters that you can use with it. ;-))

start firefox

I hope it will work for you, as well.

kind regards

To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >