Mailinglist Archive: opensuse (2058 mails)

< Previous Next >
[opensuse] Atheros AR5007EG Wireless Network Adapter and NetworkManager
  • From: "Sam Preston" <j.sam.preston@xxxxxxxxx>
  • Date: Sun, 12 Aug 2007 15:48:30 -0600
  • Message-id: <f9b550810708121448g710bc0e0je468cef3174421ff@xxxxxxxxxxxxxx>
Hi all,

I just purchased a Toshiba Satellite laptop (A215-S4807), and am
dual-booting Vista and OpenSUSE 10.2.  The laptop has an Atheros
AR5007EG wireless NIC.  After searching around, I tried installing the
ndiswrapper module and the windows drivers, and 'ndiswrapper -l'
states that everything is okay.  Unfortunately, I haven't been able to
get the connection to work.  I'm new to setting up a wireless
connetion in linux, so I'm not sure if the driver isn't working
correctly, or if I'm just not setting up the connection correctly.
'iwconfig' shows wlan0, so I try:

>iwconfig wlan0 essid "my_network_name"

after which 'iwconfig wlan0' shows signal strength, etc.  I then try:

>ifconfig wlan0 up
>ifup wlan0

I get a warning that NetworkManager is being notified to set up the
DHCP connection, but I don't seem to actually connect -- I can open up
a browser and I just get a 'page not found' error.  What should I be
doing to test this connection?  Also, the NetworkManager icon in the
system tray still says that there is a connection to eth0, not wlan0.

Thanks for any help,

-Sam

-- 
--------------------
J. Samuel Preston
Research Associate
Center for Advanced Engineering Environments
Old Dominion University Research Foundation
-- 
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups