Mailinglist Archive: opensuse (4054 mails)

< Previous Next >
Re: [SLE] Interesting TCP/IP issue
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Sat, 14 Jan 2006 16:41:38 +0100
  • Message-id: <43C91BB2.8050404@xxxxxxxxxx>
Albert wrote:
> Hi
> I’ve got a server that runs a custom daemon listening on port 4010
> outputting data received from a data logger on a RS232 port. This has now
> been running for 3 months. Every now and again there is some invalid data
> from the data logger on the RS232 port which causes an exception to be
> raised, the daemon is stopped and then restarted. It then binds to port 4010
> again and continues as normal.
> Today I was unable to connect to port 4010. The daemon could not even bind
> to port 4010. When changing the port to port 4020 or 4015 it worked without
> a problem, but changing back to port 4010 it was not possible to bind to
> port 4010.
> I did the following in order to try getting it back on:
> - stopped the daemon for about 10 minutes before starting it again
> - closed the port in the SuSE firewall to make sure there are no clients who
> are trying to connect on the port.
> None of this worked. I had to reboot the machine to get it working again.

A port isn't locked by a client's trying to connect, but it can be
locked by another server. What you should have done is to run

netstat -tupan

and see what other program has locked the port.

< Previous Next >
Follow Ups