Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Unison-gtk
  • From: Sergio Dominguez <sergio@xxxxxxxxx>
  • Date: Wed, 4 May 2005 12:36:23 +0100
  • Message-id: <20050504113623.GA18187@xxxxxxxxx>
strange, Suse 9.2

sergio@wind18:~> unison -help
Usage: unison [options]
or unison root1 root2 [options]
or unison profilename [options]

-addprefsto xxx file to add new prefs to
-addversionno add version number to name of unison executable on server
-auto automatically accept default actions
-backup xxx add a regexp to the backup list
-backups keep backup copies of files (deprecated: use 'backup')
-batch batch mode: ask no questions at all
-contactquietly Suppress the 'contacting server' message during startup
-debug xxx debug module xxx ('all' -> everything, 'verbose' -> more)
-doc xxx show documentation ('-doc topics' lists topics)
-dumbtty do not try to change terminal settings in text UI
-editor xxx command for displaying the output of the merge program
-fastcheck xxx do fast update detection (`true', `false', or `default')
-follow xxx add a regexp to the follow list
-force xxx force changes from this replica to the other
-group synchronize group
-height n height (in lines) of main window in graphical interface
-ignore xxx add a regexp to the ignore list
-ignorecase ignore upper/lowercase spelling of filenames
-ignorenot xxx add a regexp to the ignorenot list
-key xxx define a keyboard shortcut for this profile
-killserver kill server when done (even when using sockets)
-label xxx provide a descriptive string label for this profile
-log record actions in file specified by logfile preference
-logfile xxx Log file name
-maxbackups n number of backed up versions of a file
-merge xxx command for merging conflicting files
-merge2 xxx command for merging files (when no common version exists)
-numericids don't map uid/gid values by user/group names
-owner synchronize owner
-path xxx path to synchronize
-perms n part of the permissions which is synchronized
-prefer xxx choose this replica's version for conflicting changes
-root xxx root of a replica
-rootalias xxx Register alias for canonical root names
-rshargs xxx other arguments (if any) for remote shell command
-rshcmd xxx path to the rsh executable
-servercmd xxx name of unison executable on remote server
-silent print nothing (except error messages)
-socket xxx act as a server on a socket
-sortbysize list changed files by size, not name
-sortfirst xxx add a regexp to the sortfirst list
-sortlast xxx add a regexp to the sortlast list
-sortnewfirst list new before changed files
-sshcmd xxx path to the ssh executable
-statusdepth n status display depth for local files
-terse suppress status messages
-testserver exit immediately after the connection to the server
-times synchronize modification times
-ui xxx select user interface ('text' or 'graphic')
-version print version and exit
-xferbycopying optimize transfers using local copies, if possible


On Wed, May 04, 2005 at 11:31:23AM +0100, Dave Howorth said:
> Dave Howorth wrote:
> >James Oakley wrote:
> >
> >>On Thursday 07 April 2005 2:03 pm, Even Sandsmark wrote:
> >>
> >>>I am looking for Unison-gtk
> >>>i am using it on my debian machines, however i am unable to find
> >>>a rpm or source package.
> >>
> >>
> >>In SUSE, the unison package contains both. If your DISPLAY is set, the
> >>gtk version is used when you run "unison".
> >
> >
> >I'm also trying to use unison on SuSE after using it on Debian. unison
> >is installed on my suse 9.2 and yast says it is 2.9.1-385 x86_64 (it's
> >an Opteron box).
> Actually, that's wrong. This one's a Xeon box.
> But I can't persuade unison to behave in any way I
> >recognize.
> >
> >For example, I've read the suse admin manual and it says I should be
> >able to type unison --help, but that gives: Unknown option --help. Also,
> >following the official unison manual and my Debian experience, I've
> >tried unison -help but that is also an unknown option. The same goes for
> >--version, whilst -version gives: No bytecode file specified. The word
> >bytecode is not even mentioned in the suse manual section or anywhere in
> >the official unison manual so I've no idea what that means!
> >
> >After reading James' reply above, I've unset my DISPLAY but that doesn't
> >seem to make any difference.
> >
> >I'm at a loss. Is this unison or unison-gtk that I'm running? I want to
> >run the CLI/batch version, not unison-gtk, because ultimately I want it
> >to run as a remote server. How can I run unison? Is there some other
> >documentation?
> >
> >Thanks and regards, Dave
> >
> >
> --
> Dave Howorth
> MRC Centre for Protein Engineering
> Hills Road, Cambridge, CB2 2QH
> 01223 252960
> --
> Check the headers for your unsubscription address
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the archives at
> Please read the FAQs: suse-linux-e-faq@xxxxxxxx

If someone can point me to a good and _FREE_ backup software that keeps
track of which files get stored on which tape, we can change to it.
-- Mike Neuffer, admin of i-Connect Corp.

< Previous Next >