Mailinglist Archive: opensuse (3138 mails)

< Previous Next >
sudden excitement in a partition table
  • From: Andrew Brown <seatrout@xxxxxxxxx>
  • Date: Sun, 12 Dec 2004 09:47:01 +0000
  • Message-id: <4da3dd2041212014744cba738@xxxxxxxxxxxxxx>
I have Suse 9.1, kept up to date with YOU, running on ancient machine
with a 30GB IBM deskstar that used to have windows on it. The bios is
from 1999, and won't handle drives bigger than 36GB, but that is not a
problem withthis disk.

In theory, it dual boots, but in practice it is only ever booted into
linux and left there to run as a file server. I have been changing
some of the Windows FAT 32 partitions over to reiserfs for the sake of
privacy and access control. The first time I tried this, with Yast, it
went wthout trouble. I took one of the small, spare Windows partitions
and changed it to reiserFS. at some time last month.

Yesterday I tried the same trick on another partition. The disk
partitioning part of Yast segfaulted. I then tried parted, which told

"Error: The partition table on /dev/hda is inconsistent. There are many reasons
why this might be the case. However, the most likely reason is that Linux
detected the BIOS geometry for /dev/hda incorrectly. GNU Parted suspects the
real geometry should be 3737/255/63 (not 1961/255/120). You should check with
your BIOS first, as this may not be correct. You can inform Linux by adding the
parameter hda=3737,255,63 to the command line. See the LILO or GRUB
documentation for more information. If you think Parted's suggested geometry is
correct, you may select Ignore to continue (and fix Linux later). Otherwise,
select Cancel (and fix Linux and/or the BIOS now)."

So I cancelled.

Everything seems to be working fine, though obviously it is backed up
in case. There is nothing in dmesg about partition tables: The
relevant bit, I think, is

"hda: IBM-DTLA-307030, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: Hewlett-Packard CD-Writer Plus 8200, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 60036480 sectors (30738 MB) w/1916KiB Cache, CHS=3737/255/120, UDMA(33)
hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 hda12 hda13 hda14 hda15
ide-floppy driver 0.99.newide"

At this point I feel stuck. There is obviously somethig funny with the
partition table which was not there a month ago. I don't know whether
this has anything to do with upgrading the kernel since then, to
2.6.5-7.111 (apparently), which you did. I suspect it may. There was
some report on the suse support database about a bugged version of
parted being shipped with 9.1, that could, under some circustances,
break partition tables.

Has anyone else had similar problems? Should I just keep going and
hope for the best?
Or is there a known fix, prefereably one that does not involve wasting
a day on reinstallation of stuff?

Andrew Brown
What I do:
What I'm up to:

< Previous Next >
Follow Ups