Mailinglist Archive: opensuse (4020 mails)

< Previous Next >
Re: [SLE] Booting Problem
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Thu, 7 Oct 2004 07:10:29 +0200
  • Message-id: <200410070710.30094.andjoh@xxxxxxxxxx>
On Thursday, 7 October 2004 04.30, Jerome Lyles wrote:
> I was following Carl Spitzer's advice concerning getting my firewire drive
> to let me write to it(It worked,thanks Carl). He also noticed that in my
> fstab I had my floppy and dvdrecorder devices under subfs and he suggested
> I add 'users' to the fs= part of the media under subfs,which I did using
> vim. But I still couldn't write to the floppy even though I owned it. So
> I decided to run SuSEconfig-no help. Then I decided to reboot and this has
> led to a serious problem for me.
>
> When I reboot I get the message that: ' fsck failed, my / partition is
> being mounted read-only' and I must login as root. However when I run
> mount I get this:
> (none):~#mount

hm, why does this say (none)? It should say (repair filesystem)

> /dev/hdb2 on / type(reseiserfs) (rw)
> /dev/hdb2 on / type(reseiserfs) (rw)
> Two entries for the same file system! And the filesystem is mounted (rw).

Makes very little sense.

>
> Running: (none):~#fsck fails and I'm told to run it manually.
> But when I run fsck.reseiserfs --fix-fixable I get this:
> (none):~#fsck.reseiserfs --fix-fixable
> Partition /dev/hdb2 is mounted with write permissions, cannot check it.
> When I mount the system read-only it gets checked but nothing gets fixed.


> ps At the fsck failed login prompt I log in as root, enter init5 and
> restartx.

That is not a good idea. Few things will work, as you've noticed. You really
can't afford to ignore a corrupt root file system. If fsck fails it is for a
reason.

> This does not seem to be file system problem according to the rescue script
> on the installation dvd. So why is fsck failing at boot? Why does
> resierfsck --fix-fixable complain it can't fix the file system because it
> was mounted with write permissions? Is it supposed to be unmounted to fix?

Yes, although it can work if it's mounted read only.

> Why does mount show two instances of my root partition? How come umount
> doesn't get rid of one of them?

All excellent questions that I think will be hard to answer without seeing the
system.

My suggestion would be to boot the rescue system on the DVD and run reiserfsck
on /dev/hdb2 without mounting it

< Previous Next >
This Thread
Follow Ups
References