Mailinglist Archive: opensuse (3470 mails)

< Previous Next >
Re: [SLE] (Revisited) Works in Windoze, NOT in SuSE!?!?!?!?!?!?
  • From: "Bob S." <usr@xxxxxxxxxxx>
  • Date: Thu, 18 Sep 2003 04:29:57 -0400
  • Message-id: <200309180429.57175.usr@xxxxxxxxxxx>
On Wednesday 17 September 2003 18:37, Bernd wrote:
> On Tuesday, 16 September, 2003 18:34, Bob S. wrote:
> <snip>
> > Bernd,
> >
> > I have the exact same modem and have been using it since 7.1.
> > It has been a PITA to set it up, but once done it works very well.
> > Been through 4 upgrades since then 7.3, 8.0, 8,1, and now 8.2
> > Had to manually configure it every time even though Seems that
> > SuSE is not very user friendly for PCI modems. YAST recognizes it
> > but does not install it. It is ttyS4 It must be linked to
> > /dev/modem. I have only been able to make it work with kinternet,
> > never WVdial. Can't remember exactly but I had to make some changes
> > in KPPP and peers. I missed the earliest part of the thread so Iam
> > not sure exactly what your problem is.
> Bob S.,
> I TRULY appreciate your response! My first question to you is: Can
> you REALLY stay online as long as you want to???

Yes, Many hours at a time. IE: using apt-get I will stay on line for 4
or 5 hours downloading and updating files.
> My first thread started on 08/15 as "PPP connection keeps dropping,
> and another related problem." I learned a few things, and kept
> trying, yet without ultimate success.
> So you get an idea of what problem remains, here's the beginning of
> the thread dated 09/02, before (Revisited) was added:
> **********
> pppd keeps receiving a (SIGHUP) (exit code = 16) and drops. I get
> dropped as quick as 30 seconds, and CANNOT get past 59.4 minutes,
> I'm using 8.1 with KDE 3.1.1, with a U.S. Robotics 56K Performance
> Pro V.92 PCI modem, which is fully supported (modem drivers are in
> kernel 2.3 and higher). I manually start/stop my connection with
> WVDial or KInternet.

WVDial just does not work for me. KInternet is what I use.
> I rewired the phone line, put the modem in a new slot, removed nearby
> electrical equipment, contacted the ISP, tested on 3 different phone
> networks, used wvdialconf to setup the modem, added additional codes
> to the init string when the wvdialconf string didn't fix the problem,
> dropped my firewall, and the list goes on, and on. Then I remembered
> I still had a partition with WindozeME on it.

Really don't think that it is a physical problem.
> Set up the modem in windoze. When I checked the configuration, I
> found the init string was different. I added two more codes to the
> string in windoze, and tested it out.

I also have a dual boot system. My init string is identical in Windoze
and Linux.
> - Strange thing -
> I started several small downloads (12M total), and let it run. I was
> able to download the files, then stayed idle for a total of 5 hours
> before my ISP dropped me!!! Tried it again in windoze (to see if I
> could do it again), this time with a 78M file. Again!!! 5 hours
> went by before my ISP dropped me, and before the whole file was
> downloaded, which meant no idle time.
> - Stranger thing -
> Great! (right?) So I booted into SuSE, changed the init string to
> the SAME one I had success with in windoze (because the previous one
> wvdialconf set didn't work). Then I tested it the same way I did in
> windoze. pppd received a (SIGHUP) at 33.1 minutes and died, and then
> again at 26.6 minutes and died.

Again, I never was able to make WVDial work correctly since SuSE 7.0
> Afterward, I tried it again in windoze, and got the same 5 hours
> before my ISP dumped me.
> **********
> > You do need to know what protocol your ISP is using, PAP, CHAP, or
> > whatever and make appropriate entries in those files. Mine uses
> > PAP.
> My ISP says that they are using neither PAP, or CHAP, but a straight
> login.

Have to believe there is something n the login file. Been a long time
since I had to use a normal login file. :-) Sorry !
> > Make sure that your options file is edited properly, and that the
> > line "plugin" is in your /ppp/peers/kppp file.
> It is, and is being loaded each time pppd starts.
> >Read the ppp HOWTO. It helped me get this thing going.
> Where can I find the HOWTO? Is it a SuSE HOWTO or general linux? I
> scoured man pppd over and over in the past, and again today. I did
> find that according to the "Authentication" section of man pppd, that
> authentication must be satisfactorily completed before IPCP can be
> started. I am successfully sending and receiving IPCP transmissions
> to establish IP and DNS addresses.

I'm sorry, It is 4:30 am right now and I am really tired. Promise that I
will locate it for you and get back to you.
> This is what's happening in the KInternet logs:
> *When I am dumped -
> We are connected. (2003-09-17 09:27:47 PDT)
> pppd: Hangup (SIGHUP)
> pppd: Modem hangup
> pppd: cbcp_lowerdown
> pppd: Script /etc/ppp/ip-down started (pid 14391)
> pppd: Connection terminated.
> pppd: Connect time 59.4 minutes.
> pppd: Sent 145015 bytes, received 1541806 bytes.
> pppd: Waiting for 1 child processes...
> pppd: script /etc/ppp/ip-down, pid 14391
> pppd: Script /etc/ppp/ip-down finished (pid 14391), status = 0x0
> We are disconnected. (2003-09-17 10:27:10 PDT)
> pppd died: A modem hung up the phone (exit code 16)
> *When I take myself down -
> We are connected. (2003-09-17 12:33:04 PDT)
> Stopping connection. (2003-09-17 13:04:27 PDT)
> pppd: Terminating on signal 15.
> pppd: cbcp_lowerdown
> pppd: Script /etc/ppp/ip-down started (pid 16331)
> pppd: sent [LCP TermReq id=0x2 "User request"]
> pppd: rcvd [LCP TermAck id=0x2]
> pppd: Connection terminated.
> pppd: Connect time 31.5 minutes.
> pppd: Sent 65550 bytes, received 601502 bytes.
> pppd: Hangup (SIGHUP)
> pppd: Waiting for 1 child processes...
> pppd: script /etc/ppp/ip-down, pid 16331
> pppd: Script /etc/ppp/ip-down finished (pid 16331), status = 0x0
> We are disconnected. (2003-09-17 13:04:28 PDT)
> pppd died: pppd received a signal (exit code 5)
> I'm not sure where to go from here!!!

Hang in there. We (this list) will solve it for you.
> Bernd

Bob S.

< Previous Next >