Mailinglist Archive: opensuse (3959 mails)

< Previous Next >
Re: [SLE] no Samba server in network neighborhood
  • From: Tom Emerson <osnut@xxxxxxxxxxx>
  • Date: Tue, 07 Jan 2003 11:34:40 -0800
  • Message-id: <200301071134.40448.osnut@xxxxxxxxxxx>
On Tuesday 07 January 2003 11:05 am, FX Fraipont wrote:
> BUT ! I think I've found the culprit.
> After editing smb.conf, I ran testparm, and got "Loaded services file
> OK" and an invitation to see the dump of my services definition, I
> pressed enter, and guess what I saw?

I think you're on to something -- did you ALSO happen to notice...

> # Global parameters
> [global]
> server string = Samba Server

Your "original posting" of your smb.conf file listed the global section as

> [global]
> server string = Vertigo Samba Server

your SERVER STRING is different than testparm reports!

you have a bunch of "other things" that testparm didn't report [though most
are probably defaults anyway (though when I ran testparm myself, I saw there
was "a lot" of output beyond "security = USER" -- I suspect you chopped this
in your post?)]

I'm thinking [and I *might* be off my rocker here] that the file you've been
editing is NOT the file samba is using for the actual configuration!!!

I ran my copy here, and noticed the first line shows what file it is

franky:~ # testparm
Load smb config files from //etc/samba/smb.conf

what does your system say [and what file are you editing?]

Processing section "[netlogon]"
Processing section "[homes]"
Processing section "[zope]"
Processing section "[web]"
Processing section "[printers]"
Loaded services file OK.

your list of "shares" from your original posting looks a lot like the
"default", did you actually enter a "custom" share [like "web" or "zope" in
my example above] and did testparm report those "shares"?

Press enter to see a dump of your service definitions

# Global parameters
coding system =
client code page = 850
code page directory = /usr/share/samba/codepages
workgroup = HOME-NET
netbios name =
netbios aliases =
netbios scope =
server string = SuSE file server (running samba %v)
interfaces =
bind interfaces only = No
security = USER
[and a bunch more lines chopped...]

I see that some things I've changed are indeed being reported by "testparm"
[workgroup, server string, etc.] Unfortunately, you chose "WORKGROUP" for
your workgroup, which is a default, so you wouldn't know if you were getting
a "custom" or "default" configuration loaded...

< Previous Next >
Follow Ups