Mailinglist Archive: opensuse (3261 mails)

< Previous Next >
Configuring XFree86 4.0.2 (SuSE 7.1)
  • From: Greg Lentz <glentz@xxxxxxxxxxxx>
  • Date: Mon, 02 Apr 2001 16:51:00 -0700
  • Message-id: <r24ict41on0kj9jch6v6im997a0c7vjk8l@xxxxxxx>

This is my first post to this list, so if I'm asking an obvious
question, that's why. Also, I am a newbie at Linux (surprise).

I performed an FTP installation of SuSE 7.1 today. When the install
concluded, I was booted straight to the command line, rather than a
graphical login. After typing startx, I determined that the X Server
had not yet been configured (which makes sense, since I was never
asked which video card and monitor I have).

After running xf86config (seemingly with no problems), I run XFree86
and get the following output:

XFree86 Version 4.0.2/ X Window System
(protocol version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
Operating System: SuSE Linux [ELF] SuSE
Module Loader present
(===) Log file: "/var/log/XFree86.0.log", Time: Mon Apr 2 16:19:07
(==) Using config file: "/etc/XF86Config"
Data incomplete in file /etc/XF86Config
Device section "Generic VGA" must have a Driver line.
(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

When reporting a problem to a server crash, please send the full
server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to feedback@xxxxxxxx

If I run "startx", I get the following message:

The file XF86_xxxx (binary of X-Server) doesn't seem to be a binary
file. Please check it or / and install a new X-Server-binary.
I'm aborting now.

Any suggestions welcomed,

Greg Lentz

< Previous Next >