Mailinglist Archive: opensuse (2009 mails)

< Previous Next >
Re: [SLE] NFS problem
  • From: bernieg1@xxxxxxxxxxxx (Bernie Gardner)
  • Date: Sat, 16 Sep 2000 14:26:25 -0000 (GMT)
  • Message-id: <XFMail.000916142625.bernieg1@xxxxxxxxxxxx>

On 16-Sep-00 zentara wrote:
> Bernie Gardner wrote:
>> I'm trying to access my home desktop computer from my laptop through NFS. I
>> think I have everything set up correctly on both machines, but when I try to
>> mount a directory I get this message:
>> mount: RPC: Program not registered
>> Can anybody explain what this means and what I do about it?
> Which commands are you giving to which machine?
> Is the laptop the server or the desktop, I'm assuming desktop.
> Generally:
> You can start the daemons manually or in yast.
> Manually, go to /sbin/init.d and enter
> ./rpc start
> .nfsserver start
> Make sure there are no errors posted.
> Start the rpc daemon on the desktop.
> Make sure you have the nfsserver started on the desktop. If you
> are using the kernel based nfsserver, make sure it is turned on in yast,
> there
> is a separate box for it. If you are using the user-space nfsserver,
> make
> sure you installed that package in series n.
> Make sure the directory you want to mount is in /etc/exports.
> Finally you may need to start the laptops nfsserver to get it
> to connect. I have seen it work where only the desktop nfsserver
> is going, but occasionally it won't connect unless I start
> rpc and nfsserver on the laptop.
> My usual commands to connect are:
> On desktop:(
> /sbin/init.d/rpc start
> /sbin/init.d/nfsserver start
> On laptop:(
> mount -t nfs /1in
> Where /1out is the directory listed in /etc/exports on the desktop,
> and /1in is my directory on the laptop.
> Sometimes it won't work unless I start rpc and nfs on the laptop,
> maybe because of a pcmcia peculiarity?

Thanks for the reply. I've done everything you suggested. I am trying to use
the desktop as server and laptop as client (though I'ld like to use them both
ways ultimately.) Anyway, I still get the same error message. I think it's
coming from the laptop before it even tries to connect to the desktop. Again,
thanks the suggestions and let me know if you have any other thoughts.

Bernie Gardner

To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at

< Previous Next >
Follow Ups