Mailinglist Archive: opensuse (2425 mails)

< Previous Next >
[SLE] (!&@#(*& Voodoo3 troubles
  • From: keith@xxxxxxxxxxxxxx (Keith Warno)
  • Date: Mon, 26 Jun 2000 15:14:57 -0400
  • Message-id: <000501bfdfa2$d116eda0$9e0a010a@xxxxxxxxxxx>


I've a pile of trouble convincing a Voodoo3 3000 to work it's evil Voodoo
magic in SuSE 6.2. A while ago there was a post on the topic in response to
a mail I sent about the Voodoo and an SB Live. I'm grateful for the
response as it has helped.. somewhat.

The Voodoo *does* work it's magic a little bit. For example I've built a
recent version of xlock against the MesaGL libs and the 3dfx modes work
pretty well (tho one or two are slow as shi*t). However, kewl things like
quake2 constantly misbehave. Some deatils:

I've installed glide and mesa stuff from the SuSE 6.2 CDs. I've also
grabbed the 3dfx device source and rebuilt it for my currently kernel. I
try running quake2 with a script that looks sort of like this:

cd /usr/local/quake2

# For meaning of MESA environmental variables see README.3dfx in the mesa
export MESA_FX_INFO=1
export MESA_GLX_FX=fullscreen


export SST_VSYNC=0
export SST_FASTMEM=1
export SST_PCIRD=1

export SSTH3_VSYNC=0
export SSTH3_FASTMEM=1
export SSTH3_PCIRD=1

./quake2 \
+set vid_ref glx \
+set gl_driver \
+set gl_mode 6 \
+set vid_fullscreen 1

Yes, I run this in X because, apparently, the Voodoo3 only does 3dfx tricks
from within X. is the shared library from the Mesa package
on the SuSE cds, NOT the one distributed with the quake2 binary from id
software. Everything starts up, but there is a problem: No textures. The
walls and other surroundings have textures, but the characters (enemies,
etc) do not. They look like white crash test dummies. :p

Any ideas what could be a problem here? Also, gl_mode 6 is 1024x768. I
tried gl_mode 3 which is 640x480 and that was even worse. Screen looked
like rainbow static. :)

Any help would be appreciated as usual!


/* Keith Warno
** Developer & Sys Admin

To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at

< Previous Next >
Follow Ups