Mailinglist Archive: opensuse (3394 mails)

< Previous Next >
RE: [SLE] Chat script error message
  • From: gqs@xxxxxxxxxx (Graham Smith)
  • Date: Fri, 10 Mar 2000 02:34:40 +1100 (EST)
  • Message-id: <XFMail.20000310023440.gqs@xxxxxxxxxx>


I was getting this problem intermittently with a script I was using to get
E-Mail on my company's server via cron. I can't remember the exact solution to
the problem as it was a while back when I solved it among other problems.

The one thing I remember was that if my ISP was slow at responding to my pap
request it would cause this problem. From what I can remember if the ISP is
slow to repond to the PAP request the pppd program would timeout and report
the same message as below.

I would have to check the options file on the server at work to give you the
details. Unfortunatly I will not be in the office till Monday or Tuesday.

Hope this helps,

Graham Smith
On 09-Mar-2000 jeffisgod wrote:
> I'm receiving the following error message when I try to run my own
> chatscript (I can establish a connection without any problems on the
> same machine using wvdial).
> Receive serial link is not 8-bit clean:
> Problem: all had bit 7 set to 0
> Since PPP requires the serial port to be set to 8N1, this would seem to
> suggest that the data bits need to be reset from 7 to 8 bits (which
> doesn't make much sense since wvdial has no problem, unless it forces
> its own internal serial port settings).
> After checking the stty man page I tried resetting the character size
> with cs8 but it didn't change the results.
> Am I resetting the wrong option, or is the error message misleading?
> It seems the problem with the connection is that ppp never launches
> after the connection is established, but is this caused by serial port
> settings or should I be checking the pppd options instead?
> Any help or suggestions would be greatly appreciated.
> Cheers,
> Jeff

To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at

< Previous Next >
This Thread