Mailinglist Archive: opensuse-web (101 mails)

< Previous Next >
Re: [opensuse-web] Theming Issues Fixed
Am Dienstag, den 06.12.2011, 09:01 -0700 schrieb Matthew Ehle:
Hello,

A bunch of the theming issues have now been fixed.

The problem came from the new MW software using a new PHP script
(loader.php) to pull in the javascript and stylesheets instead of
having the browser pull them in directly. For security and aesthetic
purposes, I have an Apache rewrite that redirects all but a specific
list of PHP files. Since loader.php is new, it was not on that list,
and Apache wasn't letting it run. Adding that file in the RewriteCond
fixed it right up.

The good news is that we can now take advantage of centralized loading
of css and javascript. Since the majority of page loading time comes
from dozens of HTTP requests for these resources, these front end
optimizations should make the wikis *much* faster.

I don't know if that fixed the red link issue offhand, since I can't
find any pages that have broken links. Anyone who knows of a page I
can test?

-Matt

Hey,

the Toolbar from Wiki-Editor is Back! Yeah, hooray we have returned
Toolbar ;-)

And the "gallery" is back .... very cool! But wait, the gallery showed
otherwise 4 images in series and not 6 pictures. With 4 images in
series, the looks mach better .... Maybe this can plaese be corrected?

Great Job, thanks!

--
Grüße aus' m Schwabenland ↓
→ Lisufa, der Linuxsusefan ↓
##################################
**********************************
....::: openSUSE Member :::.....
*************************************************************
Die 'SuS(i)E' sei mit euch, wo immer ihr auch seid ....
*************************************************************
< Previous Next >
Follow Ups
References