Mailinglist Archive: opensuse-updates (185 mails)

< Previous Next >
openSUSE-SU-2020:0567-1: Security update for python-typed-ast
openSUSE Security Update: Security update for python-typed-ast
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0567-1
Rating: low
References: #1161562 #1161563 #1163532
Cross-References: CVE-2019-19274 CVE-2019-19275
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for python-typed-ast fixes the following issues:

python-typed-ast was reverted to version 1.3.1 because it broke another
package (bsc#1163532).


Security issues fixed:

- CVE-2019-19274: Fixed an out-of-bounds read (bsc#1161562).
- CVE-2019-19275: Fixed an out-of-bounds read (bsc#1161563).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-567=1



Package List:

- openSUSE Leap 15.1 (x86_64):

python-typed-ast-debugsource-1.3.1-lp151.2.6.1
python3-typed-ast-1.3.1-lp151.2.6.1
python3-typed-ast-debuginfo-1.3.1-lp151.2.6.1


References:

https://www.suse.com/security/cve/CVE-2019-19274.html
https://www.suse.com/security/cve/CVE-2019-19275.html
https://bugzilla.suse.com/1161562
https://bugzilla.suse.com/1161563
https://bugzilla.suse.com/1163532


< Previous Next >
This Thread
  • No further messages