Mailinglist Archive: opensuse-updates (145 mails)

< Previous Next >
openSUSE-RU-2018:1346-1: moderate: Recommended update for python3-pyOpenSSL
openSUSE Recommended Update: Recommended update for python3-pyOpenSSL
______________________________________________________________________________

Announcement ID: openSUSE-RU-2018:1346-1
Rating: moderate
References: #1073879
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update for python3-pyOpenSSL contains the following changes:

* OpenSSL.rand.egd() now uses os.urandom() to seed the internal PRNG
* Added lacking implementations: OpenSSL.SSL.Context.set_session_id,
OpenSSL.SSL.Connection.renegotiate,
OpenSSL.SSL.Connection.renegotiate_pending,
OpenSSL.SSL.Context.load_client_ca
* Fix segmentation fault when using keys larger than 4096-bit to sign data.
* Fix various errors triggered depending on client code
* Various API extensions

This version update to 16.0.0 unifies the Python 2 and Python 3 sources of
the module, as used on SLES 12.


Patch Instructions:

To install this openSUSE Recommended Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-478=1



Package List:

- openSUSE Leap 42.3 (noarch):

python3-pyOpenSSL-16.0.0-5.3.1
python3-pyOpenSSL-doc-16.0.0-5.3.1


References:

https://bugzilla.suse.com/1073879


< Previous Next >
This Thread
  • No further messages