Mailinglist Archive: opensuse-updates (82 mails)

< Previous Next >
openSUSE-SU-2018:0892-1: moderate: Security update for spice-gtk
openSUSE Security Update: Security update for spice-gtk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0892-1
Rating: moderate
References: #1085415
Cross-References: CVE-2017-12194
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for spice-gtk fixes the following issues:

- CVE-2017-12194: A flaw was found in the way spice-client processed
certain messages sent from the server. An attacker, having control of
malicious spice-server, could use this flaw to crash the client or
execute arbitrary code with permissions of the user running the client.
spice-gtk versions through 0.34 are believed to be vulnerable.
(bsc#1085415)

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-342=1



Package List:

- openSUSE Leap 42.3 (x86_64):

libspice-client-glib-2_0-8-0.33-2.3.1
libspice-client-glib-2_0-8-debuginfo-0.33-2.3.1
libspice-client-glib-helper-0.33-2.3.1
libspice-client-glib-helper-debuginfo-0.33-2.3.1
libspice-client-gtk-3_0-5-0.33-2.3.1
libspice-client-gtk-3_0-5-debuginfo-0.33-2.3.1
libspice-controller0-0.33-2.3.1
libspice-controller0-debuginfo-0.33-2.3.1
spice-gtk-0.33-2.3.1
spice-gtk-debuginfo-0.33-2.3.1
spice-gtk-debugsource-0.33-2.3.1
spice-gtk-devel-0.33-2.3.1
typelib-1_0-SpiceClientGlib-2_0-0.33-2.3.1
typelib-1_0-SpiceClientGtk-3_0-0.33-2.3.1

- openSUSE Leap 42.3 (noarch):

spice-gtk-lang-0.33-2.3.1


References:

https://www.suse.com/security/cve/CVE-2017-12194.html
https://bugzilla.suse.com/1085415


< Previous Next >
This Thread
  • No further messages