Mailinglist Archive: opensuse-updates (119 mails)

< Previous Next >
openSUSE-SU-2018:0819-1: moderate: Security update for Mozilla Thunderbird
openSUSE Security Update: Security update for Mozilla Thunderbird
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0819-1
Rating: moderate
References: #1085130 #1085671
Cross-References: CVE-2018-5125 CVE-2018-5127 CVE-2018-5129
CVE-2018-5144 CVE-2018-5145 CVE-2018-5146

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for Mozilla Thunderbird to version 52.7 fixes multiple issues.

The following bugs were fixed:

- Searching message bodies of messages in local folders, including filter
and quick filter operations, did not find content in message attachments
- Better error handling for Yahoo accounts

The following security fixes are included as part of the mozilla platform.
In general, these flaws cannot be exploited through email in Thunderbird
because scripting is disabled when reading mail, but are potentially risks
in browser or browser-like contexts (MFSA 2018-09, bsc#1085130,
bsc#1085671):

- CVE-2018-5127: Buffer overflow manipulating SVG animatedPathSegList
- CVE-2018-5129: Out-of-bounds write with malformed IPC messages
- CVE-2018-5144: Integer overflow during Unicode conversion
- CVE-2018-5146: Out of bounds memory write in libvorbis
- CVE-2018-5125: Memory safety bugs fixed in Thunderbird 52.7
- CVE-2018-5145: Memory safety bugs fixed in Thunderbird 52.7


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-313=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

MozillaThunderbird-52.7-60.1
MozillaThunderbird-buildsymbols-52.7-60.1
MozillaThunderbird-debuginfo-52.7-60.1
MozillaThunderbird-debugsource-52.7-60.1
MozillaThunderbird-devel-52.7-60.1
MozillaThunderbird-translations-common-52.7-60.1
MozillaThunderbird-translations-other-52.7-60.1


References:

https://www.suse.com/security/cve/CVE-2018-5125.html
https://www.suse.com/security/cve/CVE-2018-5127.html
https://www.suse.com/security/cve/CVE-2018-5129.html
https://www.suse.com/security/cve/CVE-2018-5144.html
https://www.suse.com/security/cve/CVE-2018-5145.html
https://www.suse.com/security/cve/CVE-2018-5146.html
https://bugzilla.suse.com/1085130
https://bugzilla.suse.com/1085671


< Previous Next >
This Thread
  • No further messages