Mailinglist Archive: opensuse-updates (89 mails)

< Previous Next >
openSUSE-SU-2018:0405-1: moderate: Security update for mupdf
openSUSE Security Update: Security update for mupdf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0405-1
Rating: moderate
References: #1077407 #1077755 #1079100
Cross-References: CVE-2018-6187 CVE-2018-6192 CVE-2018-6544

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for mupdf fixes several issues.

These security issues were fixed:

- CVE-2018-6187: Prevent heap-based buffer overflow in the
do_pdf_save_document function. Remote attackers could leverage the
vulnerability to cause a denial
of service via a crafted pdf file (bsc#1077407).
- CVE-2018-6544: pdf_load_obj_stm could have referenced the object stream
recursively and therefore run out of error stack, which allowed remote
attackers to cause a denial of service via a crafted PDF document
(bsc#1079100).
- CVE-2018-6192: The pdf_read_new_xref function allowed remote attackers
to cause a denial of service (segmentation violation and application
crash) via a crafted pdf file (bsc#1077755).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-149=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

mupdf-1.12.0-28.1
mupdf-devel-static-1.12.0-28.1


References:

https://www.suse.com/security/cve/CVE-2018-6187.html
https://www.suse.com/security/cve/CVE-2018-6192.html
https://www.suse.com/security/cve/CVE-2018-6544.html
https://bugzilla.suse.com/1077407
https://bugzilla.suse.com/1077755
https://bugzilla.suse.com/1079100


< Previous Next >
This Thread
  • No further messages