Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2018:0399-1: moderate: spice-vdagent
openSUSE Security Update: spice-vdagent

Announcement ID: openSUSE-SU-2018:0399-1
Rating: moderate
References: #1012215 #1070724
Cross-References: CVE-2017-15108
Affected Products:
openSUSE Leap 42.3

An update that solves one vulnerability and has one errata
is now available.


This update for spice-vdagent provides the following fixes:

This security issue was fixed:

- CVE-2017-15108: Properly escape save directory that is passed to the
shell to prevent local attacker with access to the session the agent
runs from injecting arbitrary commands to be executed (bsc#1070724).

This non-security issue was fixed:

- Implement endian swapping, required for big-endian guests to connect to
the spice client successfully. (bsc#1012215)

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-144=1

To bring your system up-to-date, use "zypper patch".

Package List:

- openSUSE Leap 42.3 (x86_64):



< Previous Next >
This Thread
  • No further messages