Mailinglist Archive: opensuse-updates (126 mails)

< Previous Next >
openSUSE-SU-2018:0322-1: moderate: Security update for libvirt
openSUSE Security Update: Security update for libvirt
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0322-1
Rating: moderate
References: #1035442 #1052825 #1062571 #1062760 #1064947
#1065766 #1070130 #1072887 #1073973 #1076500

Cross-References: CVE-2018-5748
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has 9 fixes is
now available.

Description:

This update for libvirt provides several fixes.

This security issue was fixed:

- CVE-2018-5748: Prevent resource exhaustion via qemuMonitorIORead()
method which allowed to cause DoS (bsc#1076500).

These security issues were fixed:

- Add a qemu hook script providing functionality similar to Xen's
block-dmmd script. (fate#324177)
- schema: Make disk driver name attribute optional. (bsc#1073973)
- virt-create-rootfs: Handle all SLE 12 versions. (bsc#1072887)
- libvirt-guests: Fix the 'stop' operation when action is 'suspend'.
(bsc#1070130)
- s390: Fix missing host cpu model info. (bsc#1065766)
- cpu: Add new EPYC CPU model. (bsc#1052825, fate#324038)
- pci: Fix the detection of the link's maximum speed. (bsc#1064947)
- nodedev: Increase the netlink socket buffer size. (bsc#1035442)
- storage: Fix a race between the volume creation and the pool refresh.
(bsc#1062571)
- daemon: Drop the minsize directive from hypervisor logrotate files.
(bsc#1062760)

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-115=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libvirt-3.3.0-12.1
libvirt-admin-3.3.0-12.1
libvirt-admin-debuginfo-3.3.0-12.1
libvirt-client-3.3.0-12.1
libvirt-client-debuginfo-3.3.0-12.1
libvirt-daemon-3.3.0-12.1
libvirt-daemon-config-network-3.3.0-12.1
libvirt-daemon-config-nwfilter-3.3.0-12.1
libvirt-daemon-debuginfo-3.3.0-12.1
libvirt-daemon-driver-interface-3.3.0-12.1
libvirt-daemon-driver-interface-debuginfo-3.3.0-12.1
libvirt-daemon-driver-lxc-3.3.0-12.1
libvirt-daemon-driver-lxc-debuginfo-3.3.0-12.1
libvirt-daemon-driver-network-3.3.0-12.1
libvirt-daemon-driver-network-debuginfo-3.3.0-12.1
libvirt-daemon-driver-nodedev-3.3.0-12.1
libvirt-daemon-driver-nodedev-debuginfo-3.3.0-12.1
libvirt-daemon-driver-nwfilter-3.3.0-12.1
libvirt-daemon-driver-nwfilter-debuginfo-3.3.0-12.1
libvirt-daemon-driver-qemu-3.3.0-12.1
libvirt-daemon-driver-qemu-debuginfo-3.3.0-12.1
libvirt-daemon-driver-secret-3.3.0-12.1
libvirt-daemon-driver-secret-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-3.3.0-12.1
libvirt-daemon-driver-storage-core-3.3.0-12.1
libvirt-daemon-driver-storage-core-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-disk-3.3.0-12.1
libvirt-daemon-driver-storage-disk-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-iscsi-3.3.0-12.1
libvirt-daemon-driver-storage-iscsi-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-logical-3.3.0-12.1
libvirt-daemon-driver-storage-logical-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-mpath-3.3.0-12.1
libvirt-daemon-driver-storage-mpath-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-scsi-3.3.0-12.1
libvirt-daemon-driver-storage-scsi-debuginfo-3.3.0-12.1
libvirt-daemon-driver-uml-3.3.0-12.1
libvirt-daemon-driver-uml-debuginfo-3.3.0-12.1
libvirt-daemon-driver-vbox-3.3.0-12.1
libvirt-daemon-driver-vbox-debuginfo-3.3.0-12.1
libvirt-daemon-hooks-3.3.0-12.1
libvirt-daemon-lxc-3.3.0-12.1
libvirt-daemon-qemu-3.3.0-12.1
libvirt-daemon-uml-3.3.0-12.1
libvirt-daemon-vbox-3.3.0-12.1
libvirt-debugsource-3.3.0-12.1
libvirt-devel-3.3.0-12.1
libvirt-doc-3.3.0-12.1
libvirt-libs-3.3.0-12.1
libvirt-libs-debuginfo-3.3.0-12.1
libvirt-lock-sanlock-3.3.0-12.1
libvirt-lock-sanlock-debuginfo-3.3.0-12.1
libvirt-nss-3.3.0-12.1
libvirt-nss-debuginfo-3.3.0-12.1

- openSUSE Leap 42.3 (x86_64):

libvirt-client-debuginfo-32bit-3.3.0-12.1
libvirt-daemon-driver-libxl-3.3.0-12.1
libvirt-daemon-driver-libxl-debuginfo-3.3.0-12.1
libvirt-daemon-driver-storage-rbd-3.3.0-12.1
libvirt-daemon-driver-storage-rbd-debuginfo-3.3.0-12.1
libvirt-daemon-xen-3.3.0-12.1
libvirt-devel-32bit-3.3.0-12.1


References:

https://www.suse.com/security/cve/CVE-2018-5748.html
https://bugzilla.suse.com/1035442
https://bugzilla.suse.com/1052825
https://bugzilla.suse.com/1062571
https://bugzilla.suse.com/1062760
https://bugzilla.suse.com/1064947
https://bugzilla.suse.com/1065766
https://bugzilla.suse.com/1070130
https://bugzilla.suse.com/1072887
https://bugzilla.suse.com/1073973
https://bugzilla.suse.com/1076500


< Previous Next >
This Thread
  • No further messages