Mailinglist Archive: opensuse-updates (126 mails)

< Previous Next >
openSUSE-SU-2018:0095-1: moderate: Security update for postgresql94
openSUSE Security Update: Security update for postgresql94
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:0095-1
Rating: moderate
References: #1062538 #1067844
Cross-References: CVE-2017-12172 CVE-2017-15098
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for postgresql94 fixes the following issues:

Security issues fixed:

- CVE-2017-15098: Fix crash due to rowtype mismatch in
json{b}_populate_recordset() (bsc#1067844).
- CVE-2017-12172: Start scripts permit database administrator to modify
root-owned files. This issue did not affect SUSE (bsc#1062538).

Bug fixes:

- Update to version 9.4.15
* https://www.postgresql.org/docs/9.4/static/release-9-4-15.html
* https://www.postgresql.org/docs/9.4/static/release-9-4-14.html

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-38=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2018-38=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

postgresql94-9.4.15-15.1
postgresql94-contrib-9.4.15-15.1
postgresql94-contrib-debuginfo-9.4.15-15.1
postgresql94-debuginfo-9.4.15-15.1
postgresql94-debugsource-9.4.15-15.1
postgresql94-devel-9.4.15-15.1
postgresql94-devel-debuginfo-9.4.15-15.1
postgresql94-libs-debugsource-9.4.15-15.1
postgresql94-plperl-9.4.15-15.1
postgresql94-plperl-debuginfo-9.4.15-15.1
postgresql94-plpython-9.4.15-15.1
postgresql94-plpython-debuginfo-9.4.15-15.1
postgresql94-pltcl-9.4.15-15.1
postgresql94-pltcl-debuginfo-9.4.15-15.1
postgresql94-server-9.4.15-15.1
postgresql94-server-debuginfo-9.4.15-15.1
postgresql94-test-9.4.15-15.1

- openSUSE Leap 42.3 (noarch):

postgresql94-docs-9.4.15-15.1

- openSUSE Leap 42.2 (i586 x86_64):

postgresql94-9.4.15-9.12.1
postgresql94-contrib-9.4.15-9.12.1
postgresql94-contrib-debuginfo-9.4.15-9.12.1
postgresql94-debuginfo-9.4.15-9.12.1
postgresql94-debugsource-9.4.15-9.12.1
postgresql94-devel-9.4.15-9.12.1
postgresql94-devel-debuginfo-9.4.15-9.12.1
postgresql94-libs-debugsource-9.4.15-9.12.1
postgresql94-plperl-9.4.15-9.12.1
postgresql94-plperl-debuginfo-9.4.15-9.12.1
postgresql94-plpython-9.4.15-9.12.1
postgresql94-plpython-debuginfo-9.4.15-9.12.1
postgresql94-pltcl-9.4.15-9.12.1
postgresql94-pltcl-debuginfo-9.4.15-9.12.1
postgresql94-server-9.4.15-9.12.1
postgresql94-server-debuginfo-9.4.15-9.12.1
postgresql94-test-9.4.15-9.12.1

- openSUSE Leap 42.2 (noarch):

postgresql94-docs-9.4.15-9.12.1


References:

https://www.suse.com/security/cve/CVE-2017-12172.html
https://www.suse.com/security/cve/CVE-2017-15098.html
https://bugzilla.suse.com/1062538
https://bugzilla.suse.com/1067844


< Previous Next >
This Thread
  • No further messages