Mailinglist Archive: opensuse-updates (98 mails)

< Previous Next >
openSUSE-SU-2017:2999-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2999-1
Rating: moderate
References: #1049379 #1050135 #1052249 #1052253 #1052545
#1054924 #1055219 #1055430 #1061873
Cross-References: CVE-2016-7530 CVE-2017-11446 CVE-2017-11534
CVE-2017-12428 CVE-2017-12431 CVE-2017-12433
CVE-2017-13133 CVE-2017-13139 CVE-2017-15033

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 9 vulnerabilities is now available.

Description:

This update for ImageMagick fixes the following issues:

Security issues fixed:

* CVE-2017-15033: A denial of service attack (memory leak) was fixed in
ReadYUVImage in coders/yuv.c [bsc#1061873]
* CVE-2017-11446: An infinite loop in ReadPESImage was fixed. (bsc#1049379)
* CVE-2017-12433: A memory leak in ReadPESImage in coders/pes.c was fixed.
(bsc#1052545)
* CVE-2017-12428: A memory leak in ReadWMFImage in coders/wmf.c was fixed.
(bsc#1052249)
* CVE-2017-12431: A use-after-free in ReadWMFImage was fixed. (bsc#1052253)
* CVE-2017-11534: A memory leak in the lite_font_map() in coders/wmf.c was
fixed. (bsc#1050135)
* CVE-2017-13133: A memory exhaustion in load_level function in
coders/xcf.c was fixed. (bsc#1055219)
* CVE-2017-13139: A out-of-bounds read in the ReadOneMNGImage was fixed.
(bsc#1055430)

This update also reverts an incorrect fix for CVE-2016-7530 [bsc#1054924].

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1270=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1270=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

ImageMagick-6.8.8.1-37.1
ImageMagick-debuginfo-6.8.8.1-37.1
ImageMagick-debugsource-6.8.8.1-37.1
ImageMagick-devel-6.8.8.1-37.1
ImageMagick-extra-6.8.8.1-37.1
ImageMagick-extra-debuginfo-6.8.8.1-37.1
libMagick++-6_Q16-3-6.8.8.1-37.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-37.1
libMagick++-devel-6.8.8.1-37.1
libMagickCore-6_Q16-1-6.8.8.1-37.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-37.1
libMagickWand-6_Q16-1-6.8.8.1-37.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-37.1
perl-PerlMagick-6.8.8.1-37.1
perl-PerlMagick-debuginfo-6.8.8.1-37.1

- openSUSE Leap 42.3 (noarch):

ImageMagick-doc-6.8.8.1-37.1

- openSUSE Leap 42.3 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-37.1
libMagick++-6_Q16-3-32bit-6.8.8.1-37.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-37.1
libMagick++-devel-32bit-6.8.8.1-37.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-37.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-37.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-37.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-37.1

- openSUSE Leap 42.2 (i586 x86_64):

ImageMagick-6.8.8.1-30.9.1
ImageMagick-debuginfo-6.8.8.1-30.9.1
ImageMagick-debugsource-6.8.8.1-30.9.1
ImageMagick-devel-6.8.8.1-30.9.1
ImageMagick-extra-6.8.8.1-30.9.1
ImageMagick-extra-debuginfo-6.8.8.1-30.9.1
libMagick++-6_Q16-3-6.8.8.1-30.9.1
libMagick++-6_Q16-3-debuginfo-6.8.8.1-30.9.1
libMagick++-devel-6.8.8.1-30.9.1
libMagickCore-6_Q16-1-6.8.8.1-30.9.1
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-30.9.1
libMagickWand-6_Q16-1-6.8.8.1-30.9.1
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-30.9.1
perl-PerlMagick-6.8.8.1-30.9.1
perl-PerlMagick-debuginfo-6.8.8.1-30.9.1

- openSUSE Leap 42.2 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-30.9.1
libMagick++-6_Q16-3-32bit-6.8.8.1-30.9.1
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-30.9.1
libMagick++-devel-32bit-6.8.8.1-30.9.1
libMagickCore-6_Q16-1-32bit-6.8.8.1-30.9.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-30.9.1
libMagickWand-6_Q16-1-32bit-6.8.8.1-30.9.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-30.9.1

- openSUSE Leap 42.2 (noarch):

ImageMagick-doc-6.8.8.1-30.9.1


References:

https://www.suse.com/security/cve/CVE-2016-7530.html
https://www.suse.com/security/cve/CVE-2017-11446.html
https://www.suse.com/security/cve/CVE-2017-11534.html
https://www.suse.com/security/cve/CVE-2017-12428.html
https://www.suse.com/security/cve/CVE-2017-12431.html
https://www.suse.com/security/cve/CVE-2017-12433.html
https://www.suse.com/security/cve/CVE-2017-13133.html
https://www.suse.com/security/cve/CVE-2017-13139.html
https://www.suse.com/security/cve/CVE-2017-15033.html
https://bugzilla.suse.com/1049379
https://bugzilla.suse.com/1050135
https://bugzilla.suse.com/1052249
https://bugzilla.suse.com/1052253
https://bugzilla.suse.com/1052545
https://bugzilla.suse.com/1054924
https://bugzilla.suse.com/1055219
https://bugzilla.suse.com/1055430
https://bugzilla.suse.com/1061873


< Previous Next >
This Thread
  • No further messages