Mailinglist Archive: opensuse-updates (123 mails)

< Previous Next >
openSUSE-SU-2017:2810-1: moderate: Security update for bluez
openSUSE Security Update: Security update for bluez
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2810-1
Rating: moderate
References: #1026652 #1057342
Cross-References: CVE-2016-7837 CVE-2017-1000250
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for bluez fixes the following vulnerabilities:

* CVE-2016-7837: Buffer overflow in parse_line function (bsc#1026652)
* CVE-2017-1000250: information disclosure vulnerability in
service_search_attr_req (bsc#1057342)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1176=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1176=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

bluez-5.41-6.1
bluez-cups-5.41-6.1
bluez-cups-debuginfo-5.41-6.1
bluez-debuginfo-5.41-6.1
bluez-debugsource-5.41-6.1
bluez-devel-5.41-6.1
bluez-test-5.41-6.1
bluez-test-debuginfo-5.41-6.1
libbluetooth3-5.41-6.1
libbluetooth3-debuginfo-5.41-6.1

- openSUSE Leap 42.3 (x86_64):

bluez-devel-32bit-5.41-6.1
libbluetooth3-32bit-5.41-6.1
libbluetooth3-debuginfo-32bit-5.41-6.1

- openSUSE Leap 42.2 (i586 x86_64):

bluez-5.41-2.5.1
bluez-cups-5.41-2.5.1
bluez-cups-debuginfo-5.41-2.5.1
bluez-debuginfo-5.41-2.5.1
bluez-debugsource-5.41-2.5.1
bluez-devel-5.41-2.5.1
bluez-test-5.41-2.5.1
bluez-test-debuginfo-5.41-2.5.1
libbluetooth3-5.41-2.5.1
libbluetooth3-debuginfo-5.41-2.5.1

- openSUSE Leap 42.2 (x86_64):

bluez-devel-32bit-5.41-2.5.1
libbluetooth3-32bit-5.41-2.5.1
libbluetooth3-debuginfo-32bit-5.41-2.5.1


References:

https://www.suse.com/security/cve/CVE-2016-7837.html
https://www.suse.com/security/cve/CVE-2017-1000250.html
https://bugzilla.suse.com/1026652
https://bugzilla.suse.com/1057342


< Previous Next >
This Thread
  • No further messages