Mailinglist Archive: opensuse-updates (123 mails)

< Previous Next >
openSUSE-SU-2017:2712-1: moderate: Security update for krb5
openSUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2712-1
Rating: moderate
References: #1032680 #1054028 #1056995 #903543
Cross-References: CVE-2017-11462
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:

This update for krb5 fixes several issues.

This security issue was fixed:

- CVE-2017-11462: Prevent automatic security context deletion to prevent
double-free (bsc#1056995)

These non-security issues were fixed:

- Set "rdns" and "dns_canonicalize_hostname" to false in krb5.conf in
order to improve client security in handling service principle names.
(bsc#1054028)
- Prevent kadmind.service startup failure caused by absence of LDAP
service. (bsc#903543)
- Remove main package's dependency on systemd (bsc#1032680)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1145=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1145=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

krb5-1.12.5-9.1
krb5-client-1.12.5-9.1
krb5-client-debuginfo-1.12.5-9.1
krb5-debuginfo-1.12.5-9.1
krb5-debugsource-1.12.5-9.1
krb5-devel-1.12.5-9.1
krb5-doc-1.12.5-9.1
krb5-mini-1.12.5-9.1
krb5-mini-debuginfo-1.12.5-9.1
krb5-mini-debugsource-1.12.5-9.1
krb5-mini-devel-1.12.5-9.1
krb5-plugin-kdb-ldap-1.12.5-9.1
krb5-plugin-kdb-ldap-debuginfo-1.12.5-9.1
krb5-plugin-preauth-otp-1.12.5-9.1
krb5-plugin-preauth-otp-debuginfo-1.12.5-9.1
krb5-plugin-preauth-pkinit-1.12.5-9.1
krb5-plugin-preauth-pkinit-debuginfo-1.12.5-9.1
krb5-server-1.12.5-9.1
krb5-server-debuginfo-1.12.5-9.1

- openSUSE Leap 42.3 (x86_64):

krb5-32bit-1.12.5-9.1
krb5-debuginfo-32bit-1.12.5-9.1
krb5-devel-32bit-1.12.5-9.1

- openSUSE Leap 42.2 (i586 x86_64):

krb5-1.12.5-6.3.1
krb5-client-1.12.5-6.3.1
krb5-client-debuginfo-1.12.5-6.3.1
krb5-debuginfo-1.12.5-6.3.1
krb5-debugsource-1.12.5-6.3.1
krb5-devel-1.12.5-6.3.1
krb5-doc-1.12.5-6.3.1
krb5-mini-1.12.5-6.3.1
krb5-mini-debuginfo-1.12.5-6.3.1
krb5-mini-debugsource-1.12.5-6.3.1
krb5-mini-devel-1.12.5-6.3.1
krb5-plugin-kdb-ldap-1.12.5-6.3.1
krb5-plugin-kdb-ldap-debuginfo-1.12.5-6.3.1
krb5-plugin-preauth-otp-1.12.5-6.3.1
krb5-plugin-preauth-otp-debuginfo-1.12.5-6.3.1
krb5-plugin-preauth-pkinit-1.12.5-6.3.1
krb5-plugin-preauth-pkinit-debuginfo-1.12.5-6.3.1
krb5-server-1.12.5-6.3.1
krb5-server-debuginfo-1.12.5-6.3.1

- openSUSE Leap 42.2 (x86_64):

krb5-32bit-1.12.5-6.3.1
krb5-debuginfo-32bit-1.12.5-6.3.1
krb5-devel-32bit-1.12.5-6.3.1


References:

https://www.suse.com/security/cve/CVE-2017-11462.html
https://bugzilla.suse.com/1032680
https://bugzilla.suse.com/1054028
https://bugzilla.suse.com/1056995
https://bugzilla.suse.com/903543


< Previous Next >
This Thread
  • No further messages