Mailinglist Archive: opensuse-updates (123 mails)

< Previous Next >
openSUSE-SU-2017:2614-1: moderate: Security update for git
openSUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2614-1
Rating: moderate
References: #1061041
Cross-References: CVE-2017-14867
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for git to version 2.13.6 fixes the following issues:

* CVE-2017-14867: Various Perl scripts did not use safe_pipe_capture()
instead of backticks, leaving them susceptible to end-user input
(boo#1061041)

As an additional measure, "git cvsserver" no longer is invoked by "git
daemon" by default.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1115=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

git-2.13.6-7.1
git-arch-2.13.6-7.1
git-core-2.13.6-7.1
git-core-debuginfo-2.13.6-7.1
git-credential-gnome-keyring-2.13.6-7.1
git-credential-gnome-keyring-debuginfo-2.13.6-7.1
git-cvs-2.13.6-7.1
git-daemon-2.13.6-7.1
git-daemon-debuginfo-2.13.6-7.1
git-debugsource-2.13.6-7.1
git-email-2.13.6-7.1
git-gui-2.13.6-7.1
git-svn-2.13.6-7.1
git-svn-debuginfo-2.13.6-7.1
git-web-2.13.6-7.1
gitk-2.13.6-7.1

- openSUSE Leap 42.3 (noarch):

git-doc-2.13.6-7.1


References:

https://www.suse.com/security/cve/CVE-2017-14867.html
https://bugzilla.suse.com/1061041


< Previous Next >
This Thread
  • No further messages