Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-RU-2017:2426-1: moderate: Recommended update for autoyast2
openSUSE Recommended Update: Recommended update for autoyast2
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:2426-1
Rating: moderate
References: #1047809 #1049473 #1051483 #1052145 #1054969

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that has 5 recommended fixes can now be installed.

Description:

This update for autoyast2 provides the following fixes:

- Fix a problem that classes/rules were being ignored due to the stack not
being properly initialized when evaluating multiple times (in case of a
self-update). (bsc#1051483)
- Fix a crash while applying the configuration to the system via the
"File/Apply Profile to this System" menu. (bsc#1047809)
- Make sure ask-scripts and their corresponding log files are saved to
/var/adm/autoinstall. (bsc#1049473)
- Fix running autoyast2 on installed systems by writing the init scripts
to /var/adm/autoinstall/init.d. (bsc#1052145)
- Handle packages that are missing a PGP signature but have valid digests.
(bsc#1054969)

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1044=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (noarch):

autoyast2-3.2.22-3.1
autoyast2-installation-3.2.22-3.1


References:

https://bugzilla.suse.com/1047809
https://bugzilla.suse.com/1049473
https://bugzilla.suse.com/1051483
https://bugzilla.suse.com/1052145
https://bugzilla.suse.com/1054969


< Previous Next >
This Thread
  • No further messages