Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-RU-2017:2348-1: moderate: Recommended update for libebml
openSUSE Recommended Update: Recommended update for libebml
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:2348-1
Rating: moderate
References: #1056669
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update for libebml to version 1.3.5 fixes the following issues:

* undefined behavior in EbmlElement::GetSemantic() (boo#1056669)

It also contains various upstream improvements and fixes:

* No longer insist that all mandatory elements are present,
only those for which there is no default value
* Fix reading and EBML element even though the ID was not found within the
allowed reading limit.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-997=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-997=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libebml-debugsource-1.3.5-5.1
libebml-devel-1.3.5-5.1
libebml4-1.3.5-5.1
libebml4-debuginfo-1.3.5-5.1

- openSUSE Leap 42.3 (x86_64):

libebml4-32bit-1.3.5-5.1
libebml4-debuginfo-32bit-1.3.5-5.1

- openSUSE Leap 42.2 (i586 x86_64):

libebml-debugsource-1.3.5-2.3.1
libebml-devel-1.3.5-2.3.1
libebml4-1.3.5-2.3.1
libebml4-debuginfo-1.3.5-2.3.1

- openSUSE Leap 42.2 (x86_64):

libebml4-32bit-1.3.5-2.3.1
libebml4-debuginfo-32bit-1.3.5-2.3.1


References:

https://bugzilla.suse.com/1056669


< Previous Next >
This Thread
  • No further messages