Mailinglist Archive: opensuse-updates (117 mails)

< Previous Next >
openSUSE-SU-2017:2158-1: moderate: Security update for ncurses
openSUSE Security Update: Security update for ncurses
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2158-1
Rating: moderate
References: #1046853 #1046858 #1047964 #1047965 #1049344

Cross-References: CVE-2017-10684 CVE-2017-10685 CVE-2017-11112
CVE-2017-11113
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves four vulnerabilities and has one
errata is now available.

Description:

This update for ncurses fixes the following issues:

Security issues fixed:
- CVE-2017-11112: Illegal address access in append_acs. (bsc#1047964)
- CVE-2017-11113: Dereferencing NULL pointer in _nc_parse_entry.
(bsc#1047965)
- CVE-2017-10684, CVE-2017-10685: Add modified upstream fix from ncurses
6.0 to avoid broken termcap format (bsc#1046853, bsc#1046858,
bsc#1049344)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-920=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-920=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libncurses5-5.9-59.1
libncurses5-debuginfo-5.9-59.1
libncurses6-5.9-59.1
libncurses6-debuginfo-5.9-59.1
ncurses-debugsource-5.9-59.1
ncurses-devel-5.9-59.1
ncurses-devel-debuginfo-5.9-59.1
ncurses-utils-5.9-59.1
ncurses-utils-debuginfo-5.9-59.1
tack-5.9-59.1
tack-debuginfo-5.9-59.1
terminfo-5.9-59.1
terminfo-base-5.9-59.1

- openSUSE Leap 42.3 (x86_64):

libncurses5-32bit-5.9-59.1
libncurses5-debuginfo-32bit-5.9-59.1
libncurses6-32bit-5.9-59.1
libncurses6-debuginfo-32bit-5.9-59.1
ncurses-devel-32bit-5.9-59.1
ncurses-devel-debuginfo-32bit-5.9-59.1

- openSUSE Leap 42.2 (i586 x86_64):

libncurses5-5.9-55.6.1
libncurses5-debuginfo-5.9-55.6.1
libncurses6-5.9-55.6.1
libncurses6-debuginfo-5.9-55.6.1
ncurses-debugsource-5.9-55.6.1
ncurses-devel-5.9-55.6.1
ncurses-devel-debuginfo-5.9-55.6.1
ncurses-utils-5.9-55.6.1
ncurses-utils-debuginfo-5.9-55.6.1
tack-5.9-55.6.1
tack-debuginfo-5.9-55.6.1
terminfo-5.9-55.6.1
terminfo-base-5.9-55.6.1

- openSUSE Leap 42.2 (x86_64):

libncurses5-32bit-5.9-55.6.1
libncurses5-debuginfo-32bit-5.9-55.6.1
libncurses6-32bit-5.9-55.6.1
libncurses6-debuginfo-32bit-5.9-55.6.1
ncurses-devel-32bit-5.9-55.6.1
ncurses-devel-debuginfo-32bit-5.9-55.6.1


References:

https://www.suse.com/security/cve/CVE-2017-10684.html
https://www.suse.com/security/cve/CVE-2017-10685.html
https://www.suse.com/security/cve/CVE-2017-11112.html
https://www.suse.com/security/cve/CVE-2017-11113.html
https://bugzilla.suse.com/1046853
https://bugzilla.suse.com/1046858
https://bugzilla.suse.com/1047964
https://bugzilla.suse.com/1047965
https://bugzilla.suse.com/1049344


< Previous Next >
This Thread
  • No further messages