Mailinglist Archive: opensuse-updates (124 mails)

< Previous Next >
openSUSE-SU-2017:2002-1: moderate: Security update for libical
openSUSE Security Update: Security update for libical
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2002-1
Rating: moderate
References: #1015964 #1044995 #986631 #986639
Cross-References: CVE-2016-5824 CVE-2016-5827 CVE-2016-9584

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

This update for libical fixes the following issues:

Security issues fixed:
- CVE-2016-5824: libical 1.0 allows remote attackers to cause a denial of
service (use-after-free) via a crafted ics file. (bsc#986639)
- CVE-2016-5827: The icaltime_from_string function in libical 0.47 and 1.0
allows remote attackers to cause a denial of service (out-of-bounds heap
read) via a crafted string to the icalparser_parse_string function.
(bsc#986631)
- CVE-2016-9584: libical allows remote attackers to cause a denial of
service (use-after-free) and possibly read heap memory via a crafted ics
file. (bsc#1015964)

Bug fixes:
- libical crashes while parsing timezones (bsc#1044995)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-869=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-869=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libical-debugsource-1.0.1-16.1
libical-devel-1.0.1-16.1
libical-devel-static-1.0.1-16.1
libical1-1.0.1-16.1
libical1-debuginfo-1.0.1-16.1

- openSUSE Leap 42.3 (noarch):

libical-doc-1.0.1-16.1

- openSUSE Leap 42.3 (x86_64):

libical1-32bit-1.0.1-16.1
libical1-debuginfo-32bit-1.0.1-16.1

- openSUSE Leap 42.2 (i586 x86_64):

libical-debugsource-1.0.1-13.3.1
libical-devel-1.0.1-13.3.1
libical-devel-static-1.0.1-13.3.1
libical1-1.0.1-13.3.1
libical1-debuginfo-1.0.1-13.3.1

- openSUSE Leap 42.2 (x86_64):

libical1-32bit-1.0.1-13.3.1
libical1-debuginfo-32bit-1.0.1-13.3.1

- openSUSE Leap 42.2 (noarch):

libical-doc-1.0.1-13.3.1


References:

https://www.suse.com/security/cve/CVE-2016-5824.html
https://www.suse.com/security/cve/CVE-2016-5827.html
https://www.suse.com/security/cve/CVE-2016-9584.html
https://bugzilla.suse.com/1015964
https://bugzilla.suse.com/1044995
https://bugzilla.suse.com/986631
https://bugzilla.suse.com/986639


< Previous Next >
This Thread
  • No further messages