Mailinglist Archive: opensuse-updates (124 mails)

< Previous Next >
openSUSE-SU-2017:1985-1: moderate: Security update for GraphicsMagick
openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1985-1
Rating: moderate
References: #1049072
Cross-References: CVE-2017-11403
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for GraphicsMagick fixes the following issue:

- CVE-2017-11403: A specially crafted PNG file may have have triggerd a
use-after-free flaw (boo#1049072)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-851=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-851=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-17.1
GraphicsMagick-debuginfo-1.3.25-17.1
GraphicsMagick-debugsource-1.3.25-17.1
GraphicsMagick-devel-1.3.25-17.1
libGraphicsMagick++-Q16-12-1.3.25-17.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-17.1
libGraphicsMagick++-devel-1.3.25-17.1
libGraphicsMagick-Q16-3-1.3.25-17.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-17.1
libGraphicsMagick3-config-1.3.25-17.1
libGraphicsMagickWand-Q16-2-1.3.25-17.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-17.1
perl-GraphicsMagick-1.3.25-17.1
perl-GraphicsMagick-debuginfo-1.3.25-17.1

- openSUSE Leap 42.2 (i586 x86_64):

GraphicsMagick-1.3.25-11.15.1
GraphicsMagick-debuginfo-1.3.25-11.15.1
GraphicsMagick-debugsource-1.3.25-11.15.1
GraphicsMagick-devel-1.3.25-11.15.1
libGraphicsMagick++-Q16-12-1.3.25-11.15.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-11.15.1
libGraphicsMagick++-devel-1.3.25-11.15.1
libGraphicsMagick-Q16-3-1.3.25-11.15.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-11.15.1
libGraphicsMagick3-config-1.3.25-11.15.1
libGraphicsMagickWand-Q16-2-1.3.25-11.15.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-11.15.1
perl-GraphicsMagick-1.3.25-11.15.1
perl-GraphicsMagick-debuginfo-1.3.25-11.15.1


References:

https://www.suse.com/security/cve/CVE-2017-11403.html
https://bugzilla.suse.com/1049072


< Previous Next >
This Thread
  • No further messages