Mailinglist Archive: opensuse-updates (116 mails)

< Previous Next >
openSUSE-SU-2017:1485-1: moderate: Security update for libupnp
openSUSE Security Update: Security update for libupnp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1485-1
Rating: moderate
References: #1006256 #898167 #989948
Cross-References: CVE-2016-6255 CVE-2016-8863
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update to libupnp 1.6.21 fixes the following security issues:

- various string handling issues (bsc#898167)
- CVE-2016-8863: out-of-bounds access (bsc#1006256)
- CVE-2016-6255: fix for file write via POST (bsc#989948)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-650=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libupnp-debugsource-1.6.21-4.3.1
libupnp-devel-1.6.21-4.3.1
libupnp6-1.6.21-4.3.1
libupnp6-debuginfo-1.6.21-4.3.1

- openSUSE Leap 42.2 (x86_64):

libupnp6-32bit-1.6.21-4.3.1
libupnp6-debuginfo-32bit-1.6.21-4.3.1


References:

https://www.suse.com/security/cve/CVE-2016-6255.html
https://www.suse.com/security/cve/CVE-2016-8863.html
https://bugzilla.suse.com/1006256
https://bugzilla.suse.com/898167
https://bugzilla.suse.com/989948


< Previous Next >
This Thread
  • No further messages