Mailinglist Archive: opensuse-updates (112 mails)

< Previous Next >
openSUSE-SU-2017:1413-1: moderate: Security update for GraphicsMagick
openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1413-1
Rating: moderate
References: #1036985 #1036986 #1036988 #1036990
Cross-References: CVE-2017-8350 CVE-2017-8351 CVE-2017-8353
CVE-2017-8355
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for GraphicsMagick fixes the following issues:

- CVE-2017-8350: denial of service via crafted PNG file (boo#1036985)
- CVE-2017-8351: denial of service via crafted PCD file (boo#1036986)
- CVE-2017-8353: denial of service via crafted PICT file (boo#1036988)
- CVE-2017-8355: denial of service via crafted MTV file (boo#1036990)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-616=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

GraphicsMagick-1.3.25-11.6.1
GraphicsMagick-debuginfo-1.3.25-11.6.1
GraphicsMagick-debugsource-1.3.25-11.6.1
GraphicsMagick-devel-1.3.25-11.6.1
libGraphicsMagick++-Q16-12-1.3.25-11.6.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-11.6.1
libGraphicsMagick++-devel-1.3.25-11.6.1
libGraphicsMagick-Q16-3-1.3.25-11.6.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-11.6.1
libGraphicsMagick3-config-1.3.25-11.6.1
libGraphicsMagickWand-Q16-2-1.3.25-11.6.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-11.6.1
perl-GraphicsMagick-1.3.25-11.6.1
perl-GraphicsMagick-debuginfo-1.3.25-11.6.1


References:

https://www.suse.com/security/cve/CVE-2017-8350.html
https://www.suse.com/security/cve/CVE-2017-8351.html
https://www.suse.com/security/cve/CVE-2017-8353.html
https://www.suse.com/security/cve/CVE-2017-8355.html
https://bugzilla.suse.com/1036985
https://bugzilla.suse.com/1036986
https://bugzilla.suse.com/1036988
https://bugzilla.suse.com/1036990


< Previous Next >
This Thread
  • No further messages