Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2017:1032-1: Security update for gstreamer-plugins-bad
openSUSE Security Update: Security update for gstreamer-plugins-bad
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:1032-1
Rating: low
References: #1024044 #1024068
Cross-References: CVE-2017-5843 CVE-2017-5848
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for gstreamer-plugins-bad fixes the following issues:

Security issues fixed:
- CVE-2017-5843: set stream tags to NULL after unrefing (bsc#1024044).
- CVE-2017-5848: rewrite PSM parsing to add bounds checking (bsc#1024068).

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-479=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

gstreamer-plugins-bad-1.8.3-5.3.1
gstreamer-plugins-bad-debuginfo-1.8.3-5.3.1
gstreamer-plugins-bad-debugsource-1.8.3-5.3.1
gstreamer-plugins-bad-devel-1.8.3-5.3.1
gstreamer-plugins-bad-doc-1.8.3-5.3.1
libgstadaptivedemux-1_0-0-1.8.3-5.3.1
libgstadaptivedemux-1_0-0-debuginfo-1.8.3-5.3.1
libgstbadaudio-1_0-0-1.8.3-5.3.1
libgstbadaudio-1_0-0-debuginfo-1.8.3-5.3.1
libgstbadbase-1_0-0-1.8.3-5.3.1
libgstbadbase-1_0-0-debuginfo-1.8.3-5.3.1
libgstbadvideo-1_0-0-1.8.3-5.3.1
libgstbadvideo-1_0-0-debuginfo-1.8.3-5.3.1
libgstbasecamerabinsrc-1_0-0-1.8.3-5.3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-1.8.3-5.3.1
libgstcodecparsers-1_0-0-1.8.3-5.3.1
libgstcodecparsers-1_0-0-debuginfo-1.8.3-5.3.1
libgstgl-1_0-0-1.8.3-5.3.1
libgstgl-1_0-0-debuginfo-1.8.3-5.3.1
libgstinsertbin-1_0-0-1.8.3-5.3.1
libgstinsertbin-1_0-0-debuginfo-1.8.3-5.3.1
libgstmpegts-1_0-0-1.8.3-5.3.1
libgstmpegts-1_0-0-debuginfo-1.8.3-5.3.1
libgstphotography-1_0-0-1.8.3-5.3.1
libgstphotography-1_0-0-debuginfo-1.8.3-5.3.1
libgstplayer-1_0-0-1.8.3-5.3.1
libgstplayer-1_0-0-debuginfo-1.8.3-5.3.1
libgsturidownloader-1_0-0-1.8.3-5.3.1
libgsturidownloader-1_0-0-debuginfo-1.8.3-5.3.1
libgstvdpau-1.8.3-5.3.1
libgstvdpau-debuginfo-1.8.3-5.3.1
libgstwayland-1_0-0-1.8.3-5.3.1
libgstwayland-1_0-0-debuginfo-1.8.3-5.3.1

- openSUSE Leap 42.2 (x86_64):

gstreamer-plugins-bad-32bit-1.8.3-5.3.1
gstreamer-plugins-bad-debuginfo-32bit-1.8.3-5.3.1
libgstadaptivedemux-1_0-0-32bit-1.8.3-5.3.1
libgstadaptivedemux-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstbadaudio-1_0-0-32bit-1.8.3-5.3.1
libgstbadaudio-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstbadbase-1_0-0-32bit-1.8.3-5.3.1
libgstbadbase-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstbadvideo-1_0-0-32bit-1.8.3-5.3.1
libgstbadvideo-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstbasecamerabinsrc-1_0-0-32bit-1.8.3-5.3.1
libgstbasecamerabinsrc-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstcodecparsers-1_0-0-32bit-1.8.3-5.3.1
libgstcodecparsers-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstgl-1_0-0-32bit-1.8.3-5.3.1
libgstgl-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstinsertbin-1_0-0-32bit-1.8.3-5.3.1
libgstinsertbin-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstmpegts-1_0-0-32bit-1.8.3-5.3.1
libgstmpegts-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstphotography-1_0-0-32bit-1.8.3-5.3.1
libgstphotography-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstplayer-1_0-0-32bit-1.8.3-5.3.1
libgstplayer-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgsturidownloader-1_0-0-32bit-1.8.3-5.3.1
libgsturidownloader-1_0-0-debuginfo-32bit-1.8.3-5.3.1
libgstvdpau-32bit-1.8.3-5.3.1
libgstvdpau-debuginfo-32bit-1.8.3-5.3.1
libgstwayland-1_0-0-32bit-1.8.3-5.3.1
libgstwayland-1_0-0-debuginfo-32bit-1.8.3-5.3.1

- openSUSE Leap 42.2 (noarch):

gstreamer-plugins-bad-lang-1.8.3-5.3.1


References:

https://www.suse.com/security/cve/CVE-2017-5843.html
https://www.suse.com/security/cve/CVE-2017-5848.html
https://bugzilla.suse.com/1024044
https://bugzilla.suse.com/1024068


< Previous Next >
This Thread
  • No further messages