Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2017:0994-1: moderate: Security update for gimp
openSUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0994-1
Rating: moderate
References: #1025717 #1032241
Cross-References: CVE-2007-3126
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for gimp fixes the following issues:

This security issue was fixed:

- CVE-2007-3126: Context-dependent attackers were able to cause a denial
of service via an ICO file with an InfoHeader containing a Height of
zero (bsc#1032241).

These non-security issues were fixed:

- bsc#1025717: Prefer lcms2 over lcms1 if both are available
- bgo#593576: Preven crash in PDF Import filter when importing large image
PDF or specifying high resolution


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-462=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

gimp-2.8.18-2.3.1
gimp-debuginfo-2.8.18-2.3.1
gimp-debugsource-2.8.18-2.3.1
gimp-devel-2.8.18-2.3.1
gimp-devel-debuginfo-2.8.18-2.3.1
gimp-help-browser-2.8.18-2.3.1
gimp-help-browser-debuginfo-2.8.18-2.3.1
gimp-plugin-aa-2.8.18-2.3.1
gimp-plugin-aa-debuginfo-2.8.18-2.3.1
gimp-plugins-python-2.8.18-2.3.1
gimp-plugins-python-debuginfo-2.8.18-2.3.1
libgimp-2_0-0-2.8.18-2.3.1
libgimp-2_0-0-debuginfo-2.8.18-2.3.1
libgimpui-2_0-0-2.8.18-2.3.1
libgimpui-2_0-0-debuginfo-2.8.18-2.3.1

- openSUSE Leap 42.2 (x86_64):

libgimp-2_0-0-32bit-2.8.18-2.3.1
libgimp-2_0-0-debuginfo-32bit-2.8.18-2.3.1
libgimpui-2_0-0-32bit-2.8.18-2.3.1
libgimpui-2_0-0-debuginfo-32bit-2.8.18-2.3.1

- openSUSE Leap 42.2 (noarch):

gimp-lang-2.8.18-2.3.1


References:

https://www.suse.com/security/cve/CVE-2007-3126.html
https://bugzilla.suse.com/1025717
https://bugzilla.suse.com/1032241


< Previous Next >
This Thread
  • No further messages