Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-RU-2017:0938-1: moderate: Recommended update for libsolv, libzypp, zypper
openSUSE Recommended Update: Recommended update for libsolv, libzypp, zypper
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:0938-1
Rating: moderate
References: #1007273 #1010712 #1014265 #1024909 #1025440
#1028492 #1030136 #1030827 #1030919 #731333
#926844
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has 11 recommended fixes can now be
installed.

Description:

The Software Update Stack was updated to include fixes and enhancements.

libsolv:

- Export solvable_matchesdep function, as we now use it in the bindings.
(bsc#1025440)
- New SOLVER_FLAG_STRONG_RECOMMENDS and SOLVER_FLAG_INSTALL_ALSO_UPDATES
flags.
- New matchesdep() method in bindings.
- SOLVABLE_NAME selects nevr matching for pool_whatmatchesdep and
solvable_matchesdep.
- Make solver_problemruleinfo2str return reason why a package is not
installable.
- Rework susetags multi-line handling. (bsc#1007273)
- Improve checks against corrupt rpm packages.
- Add SOLVER_FLAG_FOCUS_BEST solver flag.

libzypp:

- Fix X-libcurl-Empty-Header-Workaround. (bsc#1030919, bsc#1030827)
- Treat HTTP response 410 (Gone) like 404 (Not Found). (bsc#1030136)
- Create temporary directories inside ZYpp::tmpPath. (bsc#926844)
- Properly escape XML node content. (bsc#1024909)
- Don't raise FileCheckException if user accepted a package with wrong
digest. (bsc#1014265)

zypper:

- Share TmpDir with libzypp. (bsc#926844)
- Don't show installed system packages if list command is restricted to
repos. (bsc#1028492)
- Fix invalid XML in GPG key info output. (bsc#1024909)
- Do not warn about processes using deleted files when using --root.
(bsc#731333)
- Properly escape patch script output in xml mode. (bsc#1010712)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-440=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libsolv-debugsource-0.6.26-19.1
libsolv-demo-0.6.26-19.1
libsolv-demo-debuginfo-0.6.26-19.1
libsolv-devel-0.6.26-19.1
libsolv-devel-debuginfo-0.6.26-19.1
libsolv-tools-0.6.26-19.1
libsolv-tools-debuginfo-0.6.26-19.1
libzypp-15.24.2-19.2
libzypp-debuginfo-15.24.2-19.2
libzypp-debugsource-15.24.2-19.2
libzypp-devel-15.24.2-19.2
libzypp-devel-doc-15.24.2-19.2
perl-solv-0.6.26-19.1
perl-solv-debuginfo-0.6.26-19.1
python-solv-0.6.26-19.1
python-solv-debuginfo-0.6.26-19.1
python3-solv-0.6.26-19.1
python3-solv-debuginfo-0.6.26-19.1
ruby-solv-0.6.26-19.1
ruby-solv-debuginfo-0.6.26-19.1
zypper-1.12.50-19.1
zypper-debuginfo-1.12.50-19.1
zypper-debugsource-1.12.50-19.1

- openSUSE Leap 42.1 (noarch):

zypper-aptitude-1.12.50-19.1
zypper-log-1.12.50-19.1


References:

https://bugzilla.suse.com/1007273
https://bugzilla.suse.com/1010712
https://bugzilla.suse.com/1014265
https://bugzilla.suse.com/1024909
https://bugzilla.suse.com/1025440
https://bugzilla.suse.com/1028492
https://bugzilla.suse.com/1030136
https://bugzilla.suse.com/1030827
https://bugzilla.suse.com/1030919
https://bugzilla.suse.com/731333
https://bugzilla.suse.com/926844


< Previous Next >
This Thread
  • No further messages