Mailinglist Archive: opensuse-updates (121 mails)

< Previous Next >
openSUSE-RU-2017:0451-1: Recommended update for geany, geany-plugins
openSUSE Recommended Update: Recommended update for geany, geany-plugins
______________________________________________________________________________

Announcement ID: openSUSE-RU-2017:0451-1
Rating: low
References: #1022222
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

This update for geany, geany-plugins fixes the following issues:

- boo#1022222: The integrated terminal was not available

In addition, the Geany IDE was updated to 1.29, with the following
upstream changes:

- UI fixes related to GTK
- Fix focusing the message window when the Terminal tab is active
- Add support for keeping the cursor a number of lines from the edges to
always show some context
- Allow to configure keybinding for "Delete to beginning of line"
- Performance improvements with many duplicate symbols
- Allow to configure the error indicator color
- Fix highlighting of Haxe preprocessor
- Add `.exp` extension to TCL

The following changes are included in geany-plugins:
- Rename plugin GeanyLipsum to Lipsum
- Addons: Add a function to deselect marked words with one click
- Commander: Add keybindings for triggering a particular filter type
- Git-Changebar: Fix an issue access the git repository in combination
with libgit2 0.24.2
- Git-Changebar: Fix an off-by-one issue in tooltip hunk width calculation
cropping 1px on the right
- Fix handling of documents starting with a BOM
- Spellcheck: Strip single quotes from words' beginning and end
- Spellcheck: Fix a memory leak on duplicate dictionaries
- Treebrowser: Fix a typo in configuration parsing causing option for
"open new files" have not being save/restored correctly


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-240=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (x86_64):

geany-1.29-3.1
geany-debuginfo-1.29-3.1
geany-debugsource-1.29-3.1
geany-devel-1.29-3.1
geany-doc-1.29-3.1
geany-plugins-1.29-3.2
geany-plugins-debuginfo-1.29-3.2
geany-plugins-debugsource-1.29-3.2
libgeany0-1.29-3.1
libgeany0-debuginfo-1.29-3.1

- openSUSE Leap 42.2 (noarch):

geany-lang-1.29-3.1
geany-plugins-lang-1.29-3.2


References:

https://bugzilla.suse.com/1022222


< Previous Next >
This Thread
  • No further messages