Mailinglist Archive: opensuse-updates (121 mails)

< Previous Next >
openSUSE-SU-2017:0428-1: Security update for libplist
openSUSE Security Update: Security update for libplist
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0428-1
Rating: low
References: #1019531 #1021610
Cross-References: CVE-2017-5209 CVE-2017-5545
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libplist addresses the following vulnerabilities:

- CVE-2017-5545: OOB heap buffer read which could allow attackers to
obtain sensitive information from process memory or cause a DoS
(bsc#1021610)
- CVE-2017-5209: base64decode function could have allowed attackers to
obtain sensitive information from process memory or cause a denial of
service (buffer over-read) via split encoded Apple Property List data


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-230=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-230=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libplist++-devel-1.12-5.1
libplist++3-1.12-5.1
libplist++3-debuginfo-1.12-5.1
libplist-debugsource-1.12-5.1
libplist-devel-1.12-5.1
libplist3-1.12-5.1
libplist3-debuginfo-1.12-5.1
plistutil-1.12-5.1
plistutil-debuginfo-1.12-5.1
python-plist-1.12-5.1
python-plist-debuginfo-1.12-5.1

- openSUSE Leap 42.2 (x86_64):

libplist++3-32bit-1.12-5.1
libplist++3-debuginfo-32bit-1.12-5.1
libplist3-32bit-1.12-5.1
libplist3-debuginfo-32bit-1.12-5.1

- openSUSE Leap 42.1 (i586 x86_64):

libplist++-devel-1.12-4.1
libplist++3-1.12-4.1
libplist++3-debuginfo-1.12-4.1
libplist-debugsource-1.12-4.1
libplist-devel-1.12-4.1
libplist3-1.12-4.1
libplist3-debuginfo-1.12-4.1
plistutil-1.12-4.1
plistutil-debuginfo-1.12-4.1
python-plist-1.12-4.1
python-plist-debuginfo-1.12-4.1

- openSUSE Leap 42.1 (x86_64):

libplist++3-32bit-1.12-4.1
libplist++3-debuginfo-32bit-1.12-4.1
libplist3-32bit-1.12-4.1
libplist3-debuginfo-32bit-1.12-4.1


References:

https://www.suse.com/security/cve/CVE-2017-5209.html
https://www.suse.com/security/cve/CVE-2017-5545.html
https://bugzilla.suse.com/1019531
https://bugzilla.suse.com/1021610


< Previous Next >
This Thread
  • No further messages