Mailinglist Archive: opensuse-updates (180 mails)

< Previous Next >
openSUSE-SU-2017:0259-1: moderate: Security update for python3-sleekxmpp
openSUSE Security Update: Security update for python3-sleekxmpp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0259-1
Rating: moderate
References: #1014976
Cross-References: CVE-2015-8688 CVE-2016-9928
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for python3-sleekxmpp fixes the following issues:

- Check the origin of roster pushes (2015-8688, 2016-9928, boo#1014976).
Also see
https://gultsch.de/gajim_roster_push_and_message_interception.html
- An error in legacyauth support was fixed


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-137=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (noarch):

python3-sleekxmpp-1.3.1-3.1


References:

https://www.suse.com/security/cve/CVE-2015-8688.html
https://www.suse.com/security/cve/CVE-2016-9928.html
https://bugzilla.suse.com/1014976


< Previous Next >
This Thread
  • No further messages