Mailinglist Archive: opensuse-updates (180 mails)

< Previous Next >
openSUSE-SU-2017:0223-1: moderate: Security update for squid
openSUSE Security Update: Security update for squid
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0223-1
Rating: moderate
References: #1016168 #949942
Cross-References: CVE-2014-9749 CVE-2016-10002
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for squid fixes the following issues:

- CVE-2016-10002: Fixed incorrect processing of responses to
If-None-Modified HTTP conditional requests. This allowed responses
containing private data to clients it should not have reached
(bsc#1016168)
- CVE-2014-9749: Prevent nonce replay in Digest authentication, preventing
the reuse of stale auth tokens (bsc#949942)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-127=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

squid-3.3.14-12.1
squid-debuginfo-3.3.14-12.1
squid-debugsource-3.3.14-12.1


References:

https://www.suse.com/security/cve/CVE-2014-9749.html
https://www.suse.com/security/cve/CVE-2016-10002.html
https://bugzilla.suse.com/1016168
https://bugzilla.suse.com/949942


< Previous Next >
This Thread
  • No further messages