Mailinglist Archive: opensuse-updates (164 mails)

< Previous Next >
openSUSE-SU-2016:3089-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:3089-1
Rating: moderate
References: #1001066 #1007245
Cross-References: CVE-2016-6823 CVE-2016-8862
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


This update for ImageMagick fixes the following issues:

- Memory allocation failure in AcquireMagickMemory (CVE-2016-8862)
[bsc#1007245]
- update incomplete patch of CVE-2016-6823 [bsc#1001066]

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2016-1445=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

ImageMagick-6.8.8.1-22.2
ImageMagick-debuginfo-6.8.8.1-22.2
ImageMagick-debugsource-6.8.8.1-22.2
ImageMagick-devel-6.8.8.1-22.2
ImageMagick-extra-6.8.8.1-22.2
ImageMagick-extra-debuginfo-6.8.8.1-22.2
libMagick++-6_Q16-3-6.8.8.1-22.2
libMagick++-6_Q16-3-debuginfo-6.8.8.1-22.2
libMagick++-devel-6.8.8.1-22.2
libMagickCore-6_Q16-1-6.8.8.1-22.2
libMagickCore-6_Q16-1-debuginfo-6.8.8.1-22.2
libMagickWand-6_Q16-1-6.8.8.1-22.2
libMagickWand-6_Q16-1-debuginfo-6.8.8.1-22.2
perl-PerlMagick-6.8.8.1-22.2
perl-PerlMagick-debuginfo-6.8.8.1-22.2

- openSUSE Leap 42.2 (x86_64):

ImageMagick-devel-32bit-6.8.8.1-22.2
libMagick++-6_Q16-3-32bit-6.8.8.1-22.2
libMagick++-6_Q16-3-debuginfo-32bit-6.8.8.1-22.2
libMagick++-devel-32bit-6.8.8.1-22.2
libMagickCore-6_Q16-1-32bit-6.8.8.1-22.2
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.8.1-22.2
libMagickWand-6_Q16-1-32bit-6.8.8.1-22.2
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.8.1-22.2

- openSUSE Leap 42.2 (noarch):

ImageMagick-doc-6.8.8.1-22.2


References:

https://www.suse.com/security/cve/CVE-2016-6823.html
https://www.suse.com/security/cve/CVE-2016-8862.html
https://bugzilla.suse.com/1001066
https://bugzilla.suse.com/1007245


< Previous Next >
This Thread
  • No further messages