Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2016:2276-1: moderate: Security update for gdk-pixbuf
openSUSE Security Update: Security update for gdk-pixbuf
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:2276-1
Rating: moderate
References: #988745 #991450
Cross-References: CVE-2016-6352
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


gdk-pixbuf was updated to 2.32.3 to fix the following issues:

Update to version 2.32.3:
+ Fix two crashes in the bmp loader (bgo#747605, bgo#758991)
+ ico: integer overflow fixes
+ Avoid some integer overflow possibilities in scaling code
+ Make relocations optional
+ Fix a crash due to overflow when scaling
+ Drop loaders for some rare image formats: wbmp, ras, pcx
+ Prevent testsuite failures due to lack of memory
+ Fix animation loading (bgo#755269)
+ More overflow fixes in the scaling code (bgo#754387)
+ Fix a crash in the tga loader
+ Fix several integer overflows (bgo#753908, bgo#753569)
+ Port animations to GTask
+ Translation updates
- Add fixes for some crashes, taken from upstream git (boo#988745
boo#991450 CVE-2016-6352):


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-1071=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-1071=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

gdk-pixbuf-debugsource-2.32.3-8.1
gdk-pixbuf-devel-2.32.3-8.1
gdk-pixbuf-devel-debuginfo-2.32.3-8.1
gdk-pixbuf-query-loaders-2.32.3-8.1
gdk-pixbuf-query-loaders-debuginfo-2.32.3-8.1
libgdk_pixbuf-2_0-0-2.32.3-8.1
libgdk_pixbuf-2_0-0-debuginfo-2.32.3-8.1
typelib-1_0-GdkPixbuf-2_0-2.32.3-8.1

- openSUSE Leap 42.1 (x86_64):

gdk-pixbuf-devel-32bit-2.32.3-8.1
gdk-pixbuf-devel-debuginfo-32bit-2.32.3-8.1
gdk-pixbuf-query-loaders-32bit-2.32.3-8.1
gdk-pixbuf-query-loaders-debuginfo-32bit-2.32.3-8.1
libgdk_pixbuf-2_0-0-32bit-2.32.3-8.1
libgdk_pixbuf-2_0-0-debuginfo-32bit-2.32.3-8.1

- openSUSE Leap 42.1 (noarch):

gdk-pixbuf-lang-2.32.3-8.1

- openSUSE 13.2 (i586 x86_64):

gdk-pixbuf-debugsource-2.32.3-9.1
gdk-pixbuf-devel-2.32.3-9.1
gdk-pixbuf-devel-debuginfo-2.32.3-9.1
gdk-pixbuf-query-loaders-2.32.3-9.1
gdk-pixbuf-query-loaders-debuginfo-2.32.3-9.1
libgdk_pixbuf-2_0-0-2.32.3-9.1
libgdk_pixbuf-2_0-0-debuginfo-2.32.3-9.1
typelib-1_0-GdkPixbuf-2_0-2.32.3-9.1

- openSUSE 13.2 (noarch):

gdk-pixbuf-lang-2.32.3-9.1

- openSUSE 13.2 (x86_64):

gdk-pixbuf-devel-32bit-2.32.3-9.1
gdk-pixbuf-devel-debuginfo-32bit-2.32.3-9.1
gdk-pixbuf-query-loaders-32bit-2.32.3-9.1
gdk-pixbuf-query-loaders-debuginfo-32bit-2.32.3-9.1
libgdk_pixbuf-2_0-0-32bit-2.32.3-9.1
libgdk_pixbuf-2_0-0-debuginfo-32bit-2.32.3-9.1


References:

https://www.suse.com/security/cve/CVE-2016-6352.html
https://bugzilla.suse.com/988745
https://bugzilla.suse.com/991450


< Previous Next >
This Thread
  • No further messages