Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:1924-1: moderate: Security update for libidn
openSUSE Security Update: Security update for libidn
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1924-1
Rating: moderate
References: #990189 #990191
Cross-References: CVE-2015-8948 CVE-2016-6262 CVE-2016-6263

Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:


This libidn update to version 1.33 fixes the following issues:

Security issues fixed:
- CVE-2015-8948, CVE-2016-6262: Fixed an out-of-bounds-read when reading
one zero byte as input (bsc#990189).
- CVE-2016-6263: Fixed stringprep_utf8_nfkc_normalize to reject invalid
UTF-8 (bsc#boo#990191).

Included bugfixes:
- Fixed crash in idna_to_unicode_8z8z and idna_to_unicode_8zlz (introduced
in 1.31).
- API and ABI is backwards compatible with the previous version.
- Update gpg keyring


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-925=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libidn-debugsource-1.33-3.6.1
libidn-devel-1.33-3.6.1
libidn-tools-1.33-3.6.1
libidn-tools-debuginfo-1.33-3.6.1
libidn11-1.33-3.6.1
libidn11-debuginfo-1.33-3.6.1

- openSUSE 13.2 (x86_64):

libidn11-32bit-1.33-3.6.1
libidn11-debuginfo-32bit-1.33-3.6.1


References:

https://www.suse.com/security/cve/CVE-2015-8948.html
https://www.suse.com/security/cve/CVE-2016-6262.html
https://www.suse.com/security/cve/CVE-2016-6263.html
https://bugzilla.suse.com/990189
https://bugzilla.suse.com/990191


< Previous Next >
This Thread
  • No further messages