Mailinglist Archive: opensuse-updates (127 mails)

< Previous Next >
openSUSE-SU-2016:1683-1: moderate: Security update for libtorrent-rasterbar
openSUSE Security Update: Security update for libtorrent-rasterbar
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1683-1
Rating: moderate
References: #983228
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for libtorrent-rasterbar fixes the following issues:

- CVE-2016-5301: Crash on invalid input in http_parser could have
allowed a remote attacker to perform a denial of service attack
(boo#983228).

In addition, the package was updated to 1.0.9 / 1.16.19, fixing various
upstream bugs.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch 2016-774=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

libtorrent-rasterbar-debugsource-0.16.17-2.5.1
libtorrent-rasterbar-devel-0.16.17-2.5.1
libtorrent-rasterbar-doc-0.16.17-2.5.1
libtorrent-rasterbar7-0.16.17-2.5.1
libtorrent-rasterbar7-debuginfo-0.16.17-2.5.1
python-libtorrent-rasterbar-0.16.17-2.5.1
python-libtorrent-rasterbar-debuginfo-0.16.17-2.5.1


References:

https://bugzilla.suse.com/983228


< Previous Next >
This Thread
  • No further messages