Mailinglist Archive: opensuse-updates (133 mails)

< Previous Next >
openSUSE-SU-2016:1455-1: moderate: Security update for openssh
openSUSE Security Update: Security update for openssh
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1455-1
Rating: moderate
References: #729190 #932483 #945484 #945493 #947458 #948902
#960414 #961368 #962313 #965576 #970632 #975865

Cross-References: CVE-2015-8325 CVE-2016-1908 CVE-2016-3115

Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that solves three vulnerabilities and has 9 fixes
is now available.

Description:

This update for OpenSSH fixes three security issues.

These security issues were fixed:
- CVE-2016-3115: Sanitise input for xauth(1) (bsc#970632)
- CVE-2016-1908: Prevent X11 SECURITY circumvention when forwarding X11
connections (bsc#962313)
- CVE-2015-8325: Ignore PAM environment when using login (bsc#975865)

These non-security issues were fixed:
- Fix help output of sftp (bsc#945493)
- Restarting openssh with openssh-fips installed was not working correctly
(bsc#945484)
- Fix crashes when /proc is not available in the chroot (bsc#947458)
- Correctly parse GSSAPI KEX algorithms (bsc#961368)
- More verbose FIPS mode/CC related documentation in README.FIPS
(bsc#965576, bsc#960414)
- Fix PRNG re-seeding (bsc#960414, bsc#729190)
- Disable DH parameters under 2048 bits by default and allow lowering the
limit back to the RFC 4419 specified minimum through an option
(bsc#932483, bsc#948902)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-668=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

openssh-6.6p1-11.1
openssh-askpass-gnome-6.6p1-11.1
openssh-askpass-gnome-debuginfo-6.6p1-11.1
openssh-cavs-6.6p1-11.1
openssh-cavs-debuginfo-6.6p1-11.1
openssh-debuginfo-6.6p1-11.1
openssh-debugsource-6.6p1-11.1
openssh-fips-6.6p1-11.1
openssh-helpers-6.6p1-11.1
openssh-helpers-debuginfo-6.6p1-11.1


References:

https://www.suse.com/security/cve/CVE-2015-8325.html
https://www.suse.com/security/cve/CVE-2016-1908.html
https://www.suse.com/security/cve/CVE-2016-3115.html
https://bugzilla.suse.com/729190
https://bugzilla.suse.com/932483
https://bugzilla.suse.com/945484
https://bugzilla.suse.com/945493
https://bugzilla.suse.com/947458
https://bugzilla.suse.com/948902
https://bugzilla.suse.com/960414
https://bugzilla.suse.com/961368
https://bugzilla.suse.com/962313
https://bugzilla.suse.com/965576
https://bugzilla.suse.com/970632
https://bugzilla.suse.com/975865


< Previous Next >
List Navigation
This Thread
  • No further messages