Mailinglist Archive: opensuse-updates (137 mails)

< Previous Next >
openSUSE-SU-2016:0881-1: moderate: Security update for perl
openSUSE Security Update: Security update for perl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0881-1
Rating: moderate
References: #928292 #961528 #967082
Cross-References: CVE-2015-8607 CVE-2016-2381
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:


This update for perl fixes the following issues:

- CVE-2016-2381: Fixed environment duplicated variable handling bug
[boo#967082]
- fix memory leak in 'use utf8' handling [boo#928292]
- CVE-2015-8607: Fixed taint propagation in canonpath [boo#961528]


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-386=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

perl-5.20.1-3.1
perl-base-5.20.1-3.1
perl-base-debuginfo-5.20.1-3.1
perl-debuginfo-5.20.1-3.1
perl-debugsource-5.20.1-3.1

- openSUSE 13.2 (x86_64):

perl-32bit-5.20.1-3.1
perl-base-32bit-5.20.1-3.1
perl-base-debuginfo-32bit-5.20.1-3.1
perl-debuginfo-32bit-5.20.1-3.1

- openSUSE 13.2 (noarch):

perl-doc-5.20.1-3.1


References:

https://www.suse.com/security/cve/CVE-2015-8607.html
https://www.suse.com/security/cve/CVE-2016-2381.html
https://bugzilla.suse.com/928292
https://bugzilla.suse.com/961528
https://bugzilla.suse.com/967082


< Previous Next >
This Thread
  • No further messages