Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-SU-2016:0138-1: moderate: Security update for nodejs
openSUSE Security Update: Security update for nodejs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:0138-1
Rating: moderate
References: #948045 #956901 #956902 #961254
Cross-References: CVE-2015-6764 CVE-2015-8027
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:


This update contains nodejs 4.2.4 and fixes the following issues:

- CVE-2015-6764: unspecified out-of-bounds access vulnerability
(boo#956902)
- CVE-2015-8027: unspecified denial of service vulnerability (boo#956901)

The following non-security bugs were fixed:

- boo#948045: Nodejs 4.0 rpm does not install addon-rpm.gypi
- boo#961254: common.gypi should install at /usr/share/node and npm
requires nodejs-devel

Also contains all upstream bug fixes and improvements in the 4.2.2, 4.2.3
and 4.2.4 releases.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-46=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2016-46=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2016-46=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

nodejs-4.2.4-15.1
nodejs-debuginfo-4.2.4-15.1
nodejs-debugsource-4.2.4-15.1
nodejs-devel-4.2.4-15.1
npm-4.2.4-15.1

- openSUSE Leap 42.1 (noarch):

nodejs-docs-4.2.4-15.1

- openSUSE 13.2 (i586 x86_64):

nodejs-4.2.4-9.1
nodejs-debuginfo-4.2.4-9.1
nodejs-debugsource-4.2.4-9.1
nodejs-devel-4.2.4-9.1

- openSUSE 13.2 (noarch):

nodejs-doc-4.2.4-9.1

- openSUSE 13.1 (i586 x86_64):

nodejs-4.2.4-9.1
nodejs-debuginfo-4.2.4-9.1
nodejs-debugsource-4.2.4-9.1
nodejs-devel-4.2.4-9.1

- openSUSE 13.1 (noarch):

nodejs-doc-4.2.4-9.1


References:

https://www.suse.com/security/cve/CVE-2015-6764.html
https://www.suse.com/security/cve/CVE-2015-8027.html
https://bugzilla.suse.com/948045
https://bugzilla.suse.com/956901
https://bugzilla.suse.com/956902
https://bugzilla.suse.com/961254


< Previous Next >
This Thread
  • No further messages