Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-RU-2016:0131-1: moderate: Recommended update for conky
openSUSE Recommended Update: Recommended update for conky
______________________________________________________________________________

Announcement ID: openSUSE-RU-2016:0131-1
Rating: moderate
References: #958897
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:


This update for conky fixes the following issues:

- update version 1.10.1
+ If BUILD_IPV6=ON (default), but the user has disabled ipv6 support in
the kernel using the parameter ipv6.disable=1, then conky fails to
open /proc/net/if_inet6. This leads to a segfault when conky calls
fclose(file) regardless. This fix simply moves the fclose call into
the preceding if statement. (boo#958897)


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-41=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

conky-1.10.1-6.1
conky-debuginfo-1.10.1-6.1
conky-debugsource-1.10.1-6.1
conky-doc-1.10.1-6.1
nano-plugin-conky-1.10.1-6.1
vim-plugin-conky-1.10.1-6.1


References:

https://bugzilla.suse.com/958897


< Previous Next >
This Thread
  • No further messages