Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-SU-2015:2318-1: moderate: Security update for libressl
openSUSE Security Update: Security update for libressl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:2318-1
Rating: moderate
References: #958768
Cross-References: CVE-2015-3194 CVE-2015-3195
Affected Products:
openSUSE Leap 42.1
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

LibreSSL was updated to fix two security issues inherited from OpenSSL.

The following vulnerabilities were fixed:

* CVE-2015-3194: NULL pointer dereference in client side certificate
validation
* CVE-2015-3195: Memory leak in PKCS7 - not reachable from TLS/SSL


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-916=1

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-916=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

libcrypto36-2.3.0-7.1
libcrypto36-debuginfo-2.3.0-7.1
libressl-2.3.0-7.1
libressl-debuginfo-2.3.0-7.1
libressl-debugsource-2.3.0-7.1
libressl-devel-2.3.0-7.1
libssl37-2.3.0-7.1
libssl37-debuginfo-2.3.0-7.1
libtls9-2.3.0-7.1
libtls9-debuginfo-2.3.0-7.1

- openSUSE Leap 42.1 (x86_64):

libcrypto36-32bit-2.3.0-7.1
libcrypto36-debuginfo-32bit-2.3.0-7.1
libressl-devel-32bit-2.3.0-7.1
libssl37-32bit-2.3.0-7.1
libssl37-debuginfo-32bit-2.3.0-7.1
libtls9-32bit-2.3.0-7.1
libtls9-debuginfo-32bit-2.3.0-7.1

- openSUSE Leap 42.1 (noarch):

libressl-devel-doc-2.3.0-7.1

- openSUSE 13.2 (i586 x86_64):

libcrypto34-2.2.1-2.10.1
libcrypto34-debuginfo-2.2.1-2.10.1
libressl-2.2.1-2.10.1
libressl-debuginfo-2.2.1-2.10.1
libressl-debugsource-2.2.1-2.10.1
libressl-devel-2.2.1-2.10.1
libssl33-2.2.1-2.10.1
libssl33-debuginfo-2.2.1-2.10.1
libtls4-2.2.1-2.10.1
libtls4-debuginfo-2.2.1-2.10.1

- openSUSE 13.2 (x86_64):

libcrypto34-32bit-2.2.1-2.10.1
libcrypto34-debuginfo-32bit-2.2.1-2.10.1
libressl-devel-32bit-2.2.1-2.10.1
libssl33-32bit-2.2.1-2.10.1
libssl33-debuginfo-32bit-2.2.1-2.10.1
libtls4-32bit-2.2.1-2.10.1
libtls4-debuginfo-32bit-2.2.1-2.10.1

- openSUSE 13.2 (noarch):

libressl-devel-doc-2.2.1-2.10.1


References:

https://www.suse.com/security/cve/CVE-2015-3194.html
https://www.suse.com/security/cve/CVE-2015-3195.html
https://bugzilla.suse.com/958768


< Previous Next >
This Thread
  • No further messages