Mailinglist Archive: opensuse-updates (144 mails)

< Previous Next >
openSUSE-RU-2015:2178-1: moderate: Recommended update for julia
openSUSE Recommended Update: Recommended update for julia
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2178-1
Rating: moderate
References:
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has 0 recommended fixes can now be installed.

Description:

This recommended update provides version 0.4.1 of julia
- Version bump to 0.4.1.
* Bugfix release, no changelog available.

- Add missing runtime dependency on libpcre2-8-0

- Version bump to 0.4.0, see news.md for details.

- Remove unneeded build dependencies.
- Version bump to 0.4.0~rc4.
* Bugfix and backports towards 0.4 release. no changelog available.

- Add julia-compat package without cpu optimizations

- Version bump to 0.4.0~rc3.
* Bugfix and backports towards 0.4 release. no changelog available.

- Version bump to 0.4.0~rc2.
* Bugfix and backports towards 0.4 release. no changelog available.

- Llvm 3.3 will be bundle for 0.4 branch.
* Llvm 3.3 will be bundle until upstream change the supported version.
As it can be seen in upstream issues #9336 and #13209, there are
still many problems related with LLVM 3.5, regarding both the build
process and the JIT compiler used by Julia. Thus, it is better for
now stick with LLVM 3.3. For more information, see:
https://github.com/JuliaLang/julia/issues/13208
https://github.com/JuliaLang/julia/issues/9336

- Version bump to 0.4 branch (0.4.0~rc1).
* This version needs utf8proc > 1.3. since it is not available in
openSUSE yet, it was decided to bundle the selected upstream version.
* This version seems to build correctly with both llvm 3.5 and 3.7,
which are the versions available in 13.2 and Tumbleweed. Thus, it
was decided to build julia against system LLVM.
* The build process now requires libgit2 and pcre2.
* The changes in .spec were obtained from fedora's
julia-nightlies.spec.
- Changelog of verion 0.4.0~rc1.
* The complete list of changes related to this release candidate can
be seen in:
https://github.com/JuliaLang/julia/issues?q=milestone%3A0.4.0+is%3Aclosed

* Note: a changelog with the notable changes between 0.3 and 0.4
versions are expected in the Julia 0.4 release announcement.

- Revert: "build julia using llvm-3_3 package" (revision 15)
* The llvm-3_3 package is conflicting with other packages that depends
on llvm and it turns out that it will need a huge amount of work to
modify every package spec that depends on llvm to circumvent this
problem. Thus, by now, the safest approach is just bundle the
supported llvm version in julia package.

- Update to version 0.3.11
* Bugfix release, no changelog available

- Drop obsolete julia-disable-llvm-timestamps.patch
- Fix compiler names (clang++ -> clang++-3.3 in llvm-3_3-clang)

- Build julia using llvm-3_3 package.

- Use build-in llvm 3.3
- Disable llvm timestamps
* Julia-disable-llvm-timestamps.patch
- Drop obsolete julia_fix-building-with-mcjit-llvm.patch
- Set required memory to 4 gb

- Update to version 0.3.10
* Bugfix release, no changelog available

- Update to version 0.3.9
* Bugfix release, no changelog available

- Update to version 0.3.8
* Bugfix release, no changelog available

- Update to version 0.3.7
* Bugfix release, no changelog available

- Update to version 0.3.6
* Bugfix release, no changelog available

- Update to version 0.3.5
* Bugfix release, no changelog available

- Update to version 0.3.4
* Bugfix release, no changelog available
- Set use_system_libm=0
* If use_system_libm is set to 1, then julia will not use
openlibm.
- Set march=pentium4 (32 bits) / march=core2 (64 bits)
- Add libarpack2 to the dependency list
- Remove upstreamed julia-upstream-9221.patch

- Add julia-upstream-9221.patch to temporarily fix the upstream issue:
https://github.com/JuliaLang/julia/issues/8690

- Fix bug related with build architecture (julia_cpu_target) that was
added by revision 15 of science repo.

- Deduce julia_target_arch from rpm build flags, specifying just
JULIA_CPU_TARGET=core2 is not portable

- Update to version 0.3.3
* Bugfix release, no changelog available

- Update to version 0.3.2
* Bugfix release, no changelog available

- Update to version 0.3.1
* Bugfix release, no changelog available

- Update to version 0.3.0
* See included news.md for details
- Add _service in disabled mode for rmath and libuv sources

- Update to version 0.3.0-rc4

- Update to version 0.3.0-rc3

- Update to version 0.3.0-rc2
- Spec file cleanup
- Use system openlibm, openspecfun, utf8proc
- Use fftw3 with multithreading support
- Move build parameters to juliabuildopts file
- Move code examples to separate package

- Julia 0.3.0-rc1 (0.2.0+git4218.gc5acc8d)
- Version bump to 0.4.1.
* Bugfix release, no changelog available.

- Add missing runtime dependency on libpcre2-8-0

- Version bump to 0.4.0, see news.md for details.

- Remove unneeded build dependencies.
- Version bump to 0.4.0~rc4.
* Bugfix and backports towards 0.4 release. no changelog available.

- Add julia-compat package without cpu optimizations

- Version bump to 0.4.0~rc3.
* Bugfix and backports towards 0.4 release. no changelog available.

- Version bump to 0.4.0~rc2.
* Bugfix and backports towards 0.4 release. no changelog available.

- Llvm 3.3 will be bundle for 0.4 branch.
* Llvm 3.3 will be bundle until upstream change the supported version.
As it can be seen in upstream issues #9336 and #13209, there are
still many problems related with LLVM 3.5, regarding both the build
process and the JIT compiler used by Julia. Thus, it is better for
now stick with LLVM 3.3. For more information, see:
https://github.com/JuliaLang/julia/issues/13208
https://github.com/JuliaLang/julia/issues/9336

- Version bump to 0.4 branch (0.4.0~rc1).
* This version needs utf8proc > 1.3. since it is not available in
openSUSE yet, it was decided to bundle the selected upstream version.
* This version seems to build correctly with both llvm 3.5 and 3.7,
which are the versions available in 13.2 and Tumbleweed. Thus, it
was decided to build julia against system LLVM.
* The build process now requires libgit2 and pcre2.
* The changes in .spec were obtained from fedora's
julia-nightlies.spec.
- Changelog of verion 0.4.0~rc1.
* The complete list of changes related to this release candidate can
be seen in:
https://github.com/JuliaLang/julia/issues?q=milestone%3A0.4.0+is%3Aclosed

* Note: a changelog with the notable changes between 0.3 and 0.4
versions are expected in the Julia 0.4 release announcement.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-848=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

julia-0.4.1-4.1
julia-debuginfo-0.4.1-4.1
julia-debugsource-0.4.1-4.1
julia-devel-0.4.1-4.1
julia-devel-debuginfo-0.4.1-4.1

- openSUSE Leap 42.1 (x86_64):

julia-compat-0.4.1-4.1
julia-compat-debuginfo-0.4.1-4.1
julia-compat-debugsource-0.4.1-4.1
julia-compat-devel-0.4.1-4.1
julia-compat-devel-debuginfo-0.4.1-4.1

- openSUSE Leap 42.1 (noarch):

julia-doc-0.4.1-4.1
julia-examples-0.4.1-4.1


References:



< Previous Next >
This Thread
  • No further messages